Unable to install custom colors & fonts theme

I am unable to install a custom color theme (*.icls). 

I have done it in the past with on OSX Yosemite, but now on EL Capitan I have noticed that there are no config and/or colors folders.  Creating them does not seem to change anything.  

 

I am using PHPstorm 10.0.3 trial version on OSX El Capitan.

5 comments
Comment actions Permalink
Official comment

Hello,

*.icls files should be placed into ~/Library/Preferences/WebIde100/colors directory. If there's no colors folder then it's necessary to create it. Test it by creating a copy of existing color scheme via PhpStorm | Preferences | Editor | Colors & Fonts > Save As - *.icls file should appear there.

Comment actions Permalink

Hi there,

Please provide some details: where do you try to place your .icls file (full path to the folder)?

 

> I have noticed that there are no config and/or colors folders.

I do not remember any "config" folders (named "config") on Mac OS -- they differ to folder structure that is used on Linux/Windows.

0
Comment actions Permalink

Problem resolved: creating a custom theme while an existing colors folder exists seems to have saved the custom theme file.  

 

I had attempted every permutation of colors folder, config folder, saving themes, creating themes and nothing worked.  Potential bug maybe?

 

Thank you for the comments regardless guys, they seem to have done the trick somehow.

0
Comment actions Permalink

This is not working for me.  I confirmed the colors folder is the correct path, I saved the current theme and found it in the folder.  I moved the theme i wanted into that directory, restarted phpstorm, and it isn't there to select.  The copy of the theme is not there either from my previous save confirmation.

1
Comment actions Permalink

Kyle, I had the same problem. But then this did the trick; I "forgot" that I organized my settings (including all colors) in a git repository, so phpstorm saves THIS  colors folder NOT in /Users/yourname/Library/Preferences/PhpStorm2017.x/colors, but in /Users/yourname/Library/Preferences/PhpStorm2017.x/settingsRepository/colors. :-)

0

Please sign in to leave a comment.