Unable to launch Webstorm 2016.2 on Windows 10 Professional


The version of Java that I have installed on my windows 10 machine is

C:\>java -version
java version "1.8.0_31"
Java(TM) SE Runtime Environment (build 1.8.0_31-b13)
Java HotSpot(TM) 64-Bit Server VM (build 25.31-b07, mixed mode)
------------------------------------------------------------------------
Webstorm is installed in the following directory
C:\Program Files (x86)\JetBrains\WebStorm 2016.2

The Java Jre is installed under
C:\Program Files (x86)\Java\jdk1.8.0_25\jre

------------------------------------------------------------------------
When I attempt to launch
Webstorm 2016.2 on Windows 10 Professional,
I receive the following error:

"Unsupported Java Version"
Cannot start under Java 1.7.0_75-b13: Java 1.8 or later is required

------------------------------------------------------------------------

I understand that Webstorm 2016.2 was just released today and there may be some issues.

I also have
C:\Program Files (x86)\Java\jdk1.7.0_75
installed .

Question: Is there a possibility that Webstorm 2016.2 grabs the lowest version jre
C:\Program Files (x86)\Java\jdk1.7.0_75\jre
even though
------------------------------------------------------------------------
C:\>java -version
java version "1.8.0_31"
Java(TM) SE Runtime Environment (build 1.8.0_31-b13)
Java HotSpot(TM) 64-Bit Server VM (build 25.31-b07, mixed mode)
------------------------------------------------------------------------
is what is being shown at the DOS prompt.

Thanks in Advance.

()()()

4 comments
Comment actions Permalink

What launcher do you use to run WebStorm - is it WebStorm.exe or WebStorm64.exe?

0
Comment actions Permalink

Hi Elena,

 

I must be using WebStorm64.exe based on the information displayed below.
-----
The shortcut that was created on my Desktop through the install process says
JetBrains WebStorm 2016.2 (64)

When I mouse over the desktop icon it shows the path to be

Location: WebStorm64 (C:\Program Files (x86)\JetBrains\WebStorm 2016.2\bin)

0
Comment actions Permalink

Hmm... Normally it uses the 64-bit JDK defined in Windows Registry. Seems that it points to Java 1.7.0_75-b13 for some reason.

Please try setting WEBIDE_JDK_64 system environment variable to a path to your 64-Bit 1.8 JDK. See https://intellij-support.jetbrains.com/hc/en-us/articles/206544879-Selecting-the-JDK-version-the-IDE-will-run-under

0
Comment actions Permalink

I was able to install Webstorm2016.2 (64) bit:

Modifications to make so that Webstorm2016.2 (64) bit would run on a Windows Machine that has
2 jdks installed

Step 1: Set Windows 10 PATH System Variable
1. In Search, search for (Control Panel) and then select:
System icon in the (Control Panel)
2. Click the
"Advanced System settings" link.
3. Click Environment Variables.
Click New.

Add the following environment variable

WEBIDE_JDK_64

See Attached Image above.

_________________________________________________________________________________________
4.In the "New" System Variable window, specify the value of the PATH environment variable.

On my machine it is 

C:\Program Files (x86)\Java\jdk1.8.0_25\jre


Click OK.
Close all remaining windows by clicking OK.
()()()

0

Please sign in to leave a comment.