No Available packages in PyCharm

Answered

When I go to install packages, following the instructions at https://www.jetbrains.com/pycharm/help/installing-uninstalling-and-upgrading-packages.html, The green plus is always greyed out.  Sometimes clicking on one of the already-installed packages will make it light up green, but even when it does and I click on it, all I get for packages is is the Phrase "Nothing to Show" in the left pane.  The repositories button reveals a single line: https://pypi.python.org/pypi.  There's no change whether I make a virtualenv or not.

Ubuntu 15.10
PyCharm 5.0.4Tried with Pythons 2.7.10, 3.4.3, and 3.5

 

This forum looks pretty dead, but I've looked everywhere else I can think of

13 comments

Hi, Steven, what happens if you install Django on your virtualenv manually? 

Try to run '<path_to_your_virtual_env>/bin/pip install django' for example.

1

I don't seem to have pyenv installed on my machine, which is another thing that has me confused; I thought it cam with pycharm.  I can do it myself, but I don't want to mess anything up.  Should I just run thta command from a raw command line?

1

You don't need pyenv to execute pip install. Just create a virtualenv from PyCharm and then go to the it's bin folder, where execute pip install django, 

0

OK I did that and it said it installed, but django imports still don't resolve, even after closing and reopening the project.  Should I try ./pip ... ?

0

OK, that worked; I tried the slight variation in the SO reply.  Django is now recognized, though pip said it was outdated.  Is that something I can/should fix?  And I still can't install modules from the settings dialog

0

You don't need to update pip (though if you want you can do that by executing 'pip install --upgrade pip'.

 

As for inability to install packages from PyCharm, could you please submit an issue to youtrack.jetbrains.com/issues/PY attaching your log there. That will help to investigate what's going on.

0

Alright, I will submit it; I just didn't think it was a bug, but that I had missed something.  Thanks for your help.

0

I have a Mac with Sierra 10.12.1

PyCharm 2016.2.3
Build #PY-162.1967.10, built on September 7, 2016
JRE: 1.8.0_112-release-b343 x86_64
JVM: OpenJDK 64-Bit Server VM by JetBrains s.r.o

I created a conda environment after a fresh anaconda installation of Anaconda3-4.2.0-MacOSX-x86_64.pkg.

Normally, when I wanted to install a new package in the past, I could go to Preferences->Project Interpreter

then select the project and click the + sign.

Currently, when I click the + sign, there are no packages available.

The repositories available are:

https://pypi.python.org/pypi

https://repo.continuum.io/

I am using the newest python 3.5.2

How do I get my system back to show packages?

Thanks

1

I'm having the same exact issue. Was there a solution to this issue?

1

I am having the same issue. Have searched via Google and can't find a solution. I have Windows10, and Pycharm 2017.2 Build #PY-172.3317.103, built on July 25, 2017. JRE: 1.8.0_152-release-915-b5 amd64.

 

1

Hi! Could you please create a ticket in our bug tracker https://youtrack.jetbrains.com/issues and attach idea.log from Help | Show Log in ... there? What Python version do you use? Is it a part of Anaconda distribution?

1

it just stopped working all of sudden for me. I was able to add more modules a day or two ago.  However, reinstalling the IDE seems to fixed the issue. i'll create a ticket next time.  But there's definitely a bug there somewhere.  

1

@Guchen
Hi, I had the same issue, but this helped:
Go to Settings -> Project Interpreter -> click green "+" icon (on right) -> Manage Repositories (on bottom) -> delete https://pypi.python.org/simple -> add:

https://pypi.python.org/pypi

then click Ok. Repo will be back again as /simple, but don't worry, error should disappear and you should be able to install packages again. 

0

Please sign in to leave a comment.