Disable f10 from opening file menu, on Linux.

When using Visual Studio hotkey defaults f10 causes the file menu to open sometimes.  It can get a bit annoying when trying to step through code with f10.

Using dconf-editor and gconf-editor I removed the hot key, and even added config files to disable them, but the behavior still persists. How could I disable f10 from opening the file menu?

In ~/.gtkrc-2.0
binding "NoKeyboardNavigation" {
unbind "<shift>F10"
}

class * binding "NoKeyboardNavigation"

In ~/.config/gtk-3.0/gtk.css

@binding-set NoKeyboardNavigation {
unbind "<shift>F10"
}

* {
gtk-key-bindings: NoKeyboardNavigation
}
 

Please sign in to leave a comment.