How do I change passenger's max pool size

Hi.

 

I am running Rails server with Passenger.  According to Passenger's log and passenger-status command output, max pool size is 1 in RubyMine.

/Users/kyoshida/.rbenv/shims/ruby /Users/kyoshida/.rbenv/versions/2.2.4/bin/passenger start -a 0.0.0.0 -p 3000 --max-pool-size 1 --spawn-method conservative -e development
% passenger-status
Version : 5.0.25
Date : 2016-02-27 21:01:29 +0900
Instance: 7ZzDn8qX (nginx/1.8.1 Phusion_Passenger/5.0.25)

----------- General information -----------
Max pool size : 1
App groups : 1
Processes : 1
Requests in top-level queue : 0

So I hope to change max pool size. How do I go about doing that?

My environments

  • Mac OS X El Capitan 10.11
  • RubyMine 8.0.3
  • Ruby 2.2.4 (using rbenv)
  • Rails 4.2.4
  • Passenger 5.0.25
2 comments
Comment actions Permalink

Hello, 

sorry for the delay. At the moment, there is no option for that, but we have a corresponding request on our tracker, so please vote for it:

https://youtrack.jetbrains.com/issue/RUBY-12859 

0
Comment actions Permalink

Thank you for answering my question. I voted it.

0

Please sign in to leave a comment.