could not close the output stream for file

I'm using PhpStorm to develop my online website and using FTP Synchronization for that. everything was good but unfortunately now when i saving my file, php file not uploading and just print this error in file transfer window:

[3/4/2016 2:16 AM] Failed to transfer file 'C:\Users\hamid\PhpstormProjects\dlepersian.ir\engine\inc\hyvip.php': could not close the output stream for file "ftp://dlepersian.ir/engine/inc/hyvip.php".
24 comments
Avatar
Vladimir Luchansky
Comment actions Permalink

Hello,

Please try to enable File | Settings | Build, Execution, Deployment | Deployment > Your server > Advanced options > Passive Mode and check if the issue can be reproduced after that.

1
Comment actions Permalink

Hello, thanks for your answer, but problem happens when that option enabled.

this is my default options:

Passive Mode: Enabled

Compatibility Mode: Enabled

Always use List Command: Enabled

Encoding: utf-8

1
Comment actions Permalink

http://dlepersian.ir/phpstorm_log.zip 

I was thinking the problem maybe caused by my Server, so I changed That, But after 2-3 hours, problem happens again. this is what you want. thank you for your helps.

1
Comment actions Permalink

I have the same problem, it used to work in the passed, this doesn't happen every time

1
Comment actions Permalink

I am having this problem as well... This does not happen in FileZilla or Netbeans connecting to the same server. If I toggle between passive modes or go to the server and force a disconnect it will re-connect and work but only for a couple of uploads before throwing the error again.

This is the only deployment capable software I actually PAY for so having this as an error is frustrating when it does not work.

1
Avatar
Vladimir Luchansky
Comment actions Permalink

Thanks!

We would like to take a look at the detailed log. Please enable debug information collection by following next steps:

  1. Go to Help > Configure Debug Log Settings.
  2. Add there com.jetbrains.plugins.webDeployment line.
  3. Restart PhpStorm.
  4. Reproduce the issue.
  5. Send the IDE log file to us. You can locate it with the help of the following article: https://intellij-support.jetbrains.com/hc/en-us/articles/207241085-Locating-IDE-log-files.
0
Comment actions Permalink

Unfortunately, currently there's no solution. For the reference: https://youtrack.jetbrains.com/issue/WI-20698

0
Comment actions Permalink

Hi Eugene,

any update on this issue? When will it be resolved?

Thanks,

Michael 

0
Comment actions Permalink

Same problem here when trying to upload files to a project that was previously deployed with PHPStorm / FTP without issues.

 

EDIT: I selected every folder in the project and deployed it manually via context menu. It worked. So PHPStorm is overwhelmed by a few dozen files apparently.

0
Comment actions Permalink

Hi Michael, please check out the solution mentioned here: https://youtrack.jetbrains.com/issue/WI-47822 

Works like a charm for me.

0
Comment actions Permalink

Because another ftp client connected to same server , with same ip .

try disconnect another ftp connection .

this was works for me. 

0
Comment actions Permalink

This bug still exists in version 111 211.7442.50 june 4 2021

What I experienced: On the server side: no more incoming requests, no errors, the firewall is not blocking anything.
If I restart PHPStorm, the problem will be fixed
If the File | Settings | Build, Execution, Deployment | Deployment> Your server> Advanced options> Passive Mode check or uncheck (whichever happens, it works back there), the error will be fixed immediately.
I think some cache is cleared when the check mark is inserted or removed.
Or just smoothly PhpStorm deletes the connection stuff and re-initializes it.
It comes out very thinly if they went densely, you may come across two uploads, I don't know, but that's not good!

 

0
Comment actions Permalink

Unfortunately, there is no single solution and there could be plenty of reasons for deployment misbehaviour and logs could be a nice starting point to check out what is really happening. Before collecting these and contacting the support team, please enable the extended log level. To increase the deployment actions logging level, please add the following lines to the "Help > Diagnostic Tools > Debug Log Settings" section:
#com.intellij.ssh
#com.jetbrains.plugins.webDeployment

Afterwards, you may collect logs with the "Help > Collect Logs" menu option.

0
Comment actions Permalink

here to report the same issue. worked a few days back but since yesterday i cant upload shit, whilst the connection works fine. bug report is being sent.

ok: false alert.

in my case i just realized, that the server package was limited/full so the server refused taking any new files..

0
Comment actions Permalink

Sorry, not sure if I understand your concern, what bar?

0
Comment actions Permalink

Sometime this issue is caused when server's space is full.

0
Comment actions Permalink

Hi, I had the same issue and the space on server was full in my case.

[31.08.2022 18:40] Upload to mktp
[31.08.2022 18:40] Upload file '.../Service.php' to '/var/www/.../release/src/.../Service.php'
[31.08.2022 18:40] Failed to transfer file '.../Service.php'. Could not close the output stream for file "sftp://server-hostname/src/.../Service.php".

0
Comment actions Permalink

Dear all, I face exactly the same problem. I have been working on the concerned project for several years with PhpStorm and never had any issues with FTP uploads. I can't exactly tell when these issues started, but it's been a couple of months now for sure.

The 'workaround' I found this morning based on the above posts is that I only upload single files and before each upload I have to first disable passive mode and then re-eneable it again. This must clearly be a bug in PhpStorm (or related libraries it uses).

Kind regards,
Daniel

PS: There is more than enough server space and I have no problems uploading files using FileZilla, for example.

0
Comment actions Permalink

I have exactly the same problem. So long do I see the company can't solve this software problem? My version is: PhpStorm 2022.2.1. It is not free software.

09.09.2022 13:38] Failed to transfer file 'C:\MyCode\2022\newsletter2022\smarty\templates\users.tpl'. Could not close the output stream for file "ftp://127.0.0.1:7272/smarty/templates/users.tpl". (Connection refused: no further 

What am I supposed to do with it?

0
Comment actions Permalink

Daniel Baettig, Info Sawa23, in the Advanced options of your FTP deployment configuration, please try limiting the number of connections to 1.  Would that improve the situation?

0
Comment actions Permalink

It doesn't change anything. Other programs with this FTP work fine. The problem is PhpStorm.

[09.09.2022 15:27] Failed to transfer file 'C:\MyCode\2022\newsletter2022\smarty\templates\index.tpl'. Could not close the output stream for file "ftp://127.0.0.1:7272/smarty/templates/index.tpl". (Connection refused: no further information)

0
Comment actions Permalink

Thanks a lot for your fast reply, Eugene. I did a quick test now with setting the number of connections to 1 and it seemed to work. However, I will perform some more checks over the coming days as it sometimes works and then suddenly fails again. I will keep you posted.

Kind regards,

Daniel

0
Comment actions Permalink

Info Sawa23, please add #com.jetbrains.plugins.webDeployment to Help | Diagnostic Tools | Debug Log Settings, restart the IDE, reproduce the issue once again, and then share the logs (Help | Collect Logs and Diagnostic Data) in a support ticket (Help | Contact Support); we need to troubleshoot the issue. Thanks!

Daniel Baettig, thank you for the update; happy to hear it got a bit better!

0
Comment actions Permalink

Unfortunately, there is no ETA available on this issue resolution, sorry.

-2

Please sign in to leave a comment.