PyCharm 2016.2 shows reserved words as unresolved references

I have just installed 2016.2 over my previous 2016.1.4 professional and I see that pycharm is highlighting all Python reserved words as unresolved references. I can work just fine but it is really distracting 

 

Find attached an example

Any suggestions how to fix it?

TIA

4 comments
Comment actions Permalink

I am using the community version and have the same problem as Mariano. 

1
Comment actions Permalink

We have a bug related to having the same virtualenv defined twice in your IDE. Take a look at your list of all virtualenvs (Project Interpreter -> Click on gear -> Manage) and see if you have any interpreters with (1). Also, in the Project Tool window, see if External Libraries is empty.

If so, you'll have to find jdk.table.xml in your preferences directory on disk and manually delete the duplicate.

We thought we had eradicated this issue, but it popped up again for me just before EuroPython.

1
Comment actions Permalink

Thanks so much for your comments, Paul.

  1. If I access my virtualenvs via File -> Settings -> Project Interpreter and then click on the Gear and access More... none of my virtualenvs are duplicated. However whenever I access Edit Configurations... (Run/Debug Configurations) I can see some duplicates in there. Too bad I don't have means to delete them from that form.
  2. My external libraries are empty and I have only one jdk.table.xml in my ~/.PyCharm2016.2/config/options path

Guess I will have to wait for a patch to fix this in the immediate future, no worries.

TIA,

Mariano

0
Comment actions Permalink

The duplicates for jdk.table.xml is inside the one file, not multiple files. Meaning, look for <jdk> entries in there that point to the same interpreter.

0

Please sign in to leave a comment.