Can't insert tabs in text file.

Answered

I can't seem to insert the tab character \t into text files. I've done the following: 

Preferences -> Editor -> Other file types -> Use tab character

No luck. The only workaround I can find is to use a different editor to add tabs and then copy and paste them where I need them. Thoughts?

 

Details:

Mac OSX 10.11

PyCharm 2016.2 Pro

Emacs key bindings

4 comments
Comment actions Permalink

By default Emacs keybindings don't have tab key mapped to "insert tab character" action. So in Settings > Keymap > Tab > Add keyboard shortcut > tab key.

1
Comment actions Permalink

Please try File | Invalidate caches and restart and disable 3rd party plugins if you use any.

0
Comment actions Permalink

This keeps happening over and over..the fix (Invalidate Caches and restart) works but this happens to me twice a day...disruptive.  Does anyone know how to prevent this issue from occurring at all?

 

IntelliJ Ultimate 2018.3 Mac OX w/ Mac OS X 10.5+ keybind

0
Comment actions Permalink

Hi Kabright,

Seems to be working just fine on my side. Please try starting with defaults and without custom plugins by renaming/removing configuration and plugins folders https://intellij-support.jetbrains.com/hc/en-us/articles/206544519?

Does it help?

0

Please sign in to leave a comment.