Debugging with Chrome no longer works

I have the JetBrains IDE support chrome plugin installed. Previously I was able to click the debug in WebStorm, and it would launch my browser to the correct URL and connect. Great. But now when I click debug, it just launches a browser with _no_ URL, and I get a message waiting for connection from JetBrains IDE Support Extension. I have tried with different Chrome profiles, including the custom one that comes with Webstorm install. Same result with all.

Is this plugin broken with 2016.2?


~S

33 comments
Comment actions Permalink

No, the plugin works fine. What are you trying to debug? There is a known issues with Karma debugging (https://youtrack.jetbrains.com/issue/WEB-22121, fixed in 2016.2.2)

0
Comment actions Permalink

Oops, sorry I forgot to specify. I am trying to debug Javascript. 

Here is a video of me reproducing: http://screencast-o-matic.com/watch/cDjQhoiKYI

Let me know if there are more questions.

~Shea M.

0
Comment actions Permalink

I should also add that I am running the site via visaul studio 2015's IIS express.

0
Comment actions Permalink

Elena,

 

I have solved the issue. Somehow the port got switched from 63342 to 63343.

 

All is working now.

 

~S

1
Comment actions Permalink

I see, thanks for update:)

>Somehow the port got switched from 63342 to 63343

do you have any other JetBrains IDEs installed? Every JetBrains IDE is trying to open the default port (63342) when it starts; if some IDE is already running, this port is already bound, and the next free port (usually 63343) is used.
To avoid issues, you need to make sure that the IDE you use for javascript debugging is started first, before other IDEs. And, once such problem occurs, shut down both and then start the needed one.

0
Comment actions Permalink

I am experiencing exactly the same problem as shown in shea's screen cast. 

I'm trying to debug a Javascript project. When pressing the Run button, the page is opened in a new Chrome window as expected. When pressing the Debug button, a blank Chrome is opened without the specified url.

My debugging port is set to the default value (63342).

0
Comment actions Permalink

Ok, so after closing all Chrome windows, debugging now seems to work. Perhaps it is useful to mention this requirement in the docs and perhaps to display an error somewhere instead of just opening a blank window..

0
Comment actions Permalink

>Perhaps it is useful to mention this requirement in the docs

it's not a requirement... Normally you don't need closing Chrome to start debugging.

0
Comment actions Permalink

I saw a similar behavior on my machine. If I hit Run, a new tab will open in Chrome. If I hit Debug, nothing. I went back through the instructions and launched my app first through npm and then I was able to debug.

0
Comment actions Permalink

> If I hit Debug, nothing.

 

may be, the debugger couldn't attach to the IDE for some reason (wrong port, etc.)

 

>I went back through the instructions and launched my app first through npm and then I was able to debug.

 

don't understand how it is related to previous issue. With npm, you likely start your app (build it, start the server, etc.). You always need to do this to be able to run/debug your application, don't you?

0
Comment actions Permalink

Yes, maybe it was the port. I double-checked the port in the extension, I tried restarting Chrome and my system a few times, but that's the extent of my investigation. I was trying to start my app from a node.js "before launch" task and then debug. After I launched it using npm, I was able to debug. Maybe that's a red herring, but it's what worked. I just thought I'd post my experience in case it helps anyone else. Thanks!

0
Comment actions Permalink

>. I was trying to start my app from a node.js "before launch" task and then debug

Hmm.. Did you add your npm script that starts the server to 'before launch' section of your JavaScript Debug run configuration? This won't work: configurations launched in 'before launch' need to return an exit code - the other processes are waiting for return code to start. This is the way 'before launch' is designed - it's supposed to be used to run some sort of pre-processing before running the main process. So, the debugger is waiting for return code of your npm script and doesn't start

0
Comment actions Permalink

Thank you for the explanation, Elena.

0
Comment actions Permalink

I'm not sure if I should revive this thread or file a bug report, but I'm seeing this issue now with IntelliJ IDEA 2017.3.2. But this is the first suitable entry when searching for this issue, so I give it a try...

It worked with an earlier version of IntelliJ IDEA before the holidays (already with the new "don't need no Chrome extension anymore" feature), but now, if I start the debug configuration the chrome window does only show "about:blank" in the adress bar, not the intended URL.

I checked the Chrome version and updated it to the newest version (now 63.0.3239.132, 64 Bit on Windows 7). On the next try to launch it had an issue with the profile version. (It claimed that "the crrent profile version is newer than supported by the browser". That triggered an dialog to get feedback to Google, so I told them about it. After that I renamed the profile directory and it was recreated after the next launch without any complaints -- but still not opening the intended URL...)

The browser loads the correct page when copying the URL from the debug configuration into the adress bar. But the connection for debugging is obviously lost (no console output in IntelliJ, no "active" symbol for breakpoints...)

 Is Javascript debugging broken in this version or can I try to figure out what is wrong in my setup? It seems that there is no log entry when starting the debug session, is that correct? Can I try to set the required parameters manually (overriding the internal defaults -> browser configuration?) or would that collide with the parameters provided by the IDE?

 

0
Comment actions Permalink

No, Javascript debugging is definitely not broken in IDEA 2017.3.2. Smth must be wrong with your setup.

Is the issue the project-specific? Can you debug other projects? try creating a new project with HTML and JS file - can you debug it? Also, what does your chrome configuration (in Settings | Tools | Web Browsers) look like?

0
Comment actions Permalink

Hmm, strange, it works again.

The problem is, I can't get a grip on the change that fixed it for me: I had several reboots and a change in the network setup (back in the "real" network instead of VPN). But since these things shouldn't interfere with Chrome causing it to not getting the intended URL, my best guess is that there might be a side effect when mixing in runs of Karma from IntelliJ. At least that was what I hadn't done when it worked some weeks ago and that I avoided now.

I will try it again at some time when it doesn't interfere with my current work...

Thanks for your quick response and some ideas to look out for... At least my Chrome configuration was (and is) the default configuration, no custom changes.

0
Comment actions Permalink

I have this exact issue ALL THE TIME. Really frustrating.  As mentioned above, it's not clear why it's not working, and then why it's working again. I closed all my other windows, all my other projects, and still can't get it to work again. Was working fine a few days ago. Checked configuration, checked port (63342), don't see anything needs fixing. Still can't debug. There must be a bug somewhere in the plugin...

0
Comment actions Permalink

If anybody is interested in my solution - I rebooted my mac and got it to work again.

1
Comment actions Permalink

@Daisy, @Horst Weber: once the problem occur, does closing all Chrome instances and then re-starting debugger help? Do you have your custom profile dir specified in Chrome settings in Preferences | Tools | Web Browsers?

0
Comment actions Permalink

No. I closed all Chrome instances, all Webstorm projects, restarted, and nothing. It looks like something is not getting reset once a debugging session ends or the browser window closes.

0
Comment actions Permalink

I'm also having issues with Javascript debugging. When I click debug it opens a Chrome tab with this URL: chrome-extension://hmhgeddbohgjknpmjagkdomcpobmllji/loading.html?url=http%3A%2F%2Flocalhost%2F. Nothing happens afterwards, it's just a blank page.

0
Comment actions Permalink

@Ovidiu this just indicates that application is not yet started/debugger attached. Smth must be wrong with either your server or debugger connection

0
Comment actions Permalink

I had my resources root mapped to a Remote URL (http://localhost), and it was redundant because I already had my directory marked as a Resource Root in the project. Debugging starting working after I removed it. Still, this probably shouldn't break the debug configuration.

My old debug configuration can be seen here: https://drive.google.com/file/d/1iR3IhQkIoPLp8JPyu5RthOcun52l2_uf/view

0
Comment actions Permalink

Such URL mappings shouldn't break debugging... Even wrong mappings don't normally prevent the debugger from establishing a connection. It might be a different issue (network problems? port already bound? etc).

0
Comment actions Permalink

It doesn't seem like there are any other issues. When I remove the mapping it works and when I put it back it breaks.
I do have some mappings outside of the Resource Root and those work just fine.
I'm using PhpStorm 2017.3.4

0
Comment actions Permalink

Strange... can you share a sample project that can be used to recreate the issue?

0
Comment actions Permalink

I tracked this down to a broken symlink inside the directory that was mapped with a Remote URL. After I removed the symlink it started working.

0
Comment actions Permalink

I see, thanks for update:)

0
Comment actions Permalink

Guys, I'm going to close this thread for commenting; should you face any issue with debugging, please create a new thread; this one is already a mess

0
Comment actions Permalink

I have solved the issue. Debugging starting working after I removed it. Still, this probably shouldn't break the debug configuration. Thanks for sharing the great article with us.https://babasupport.org/browser/internet-explorer-customer-service/342

-2

Please sign in to leave a comment.