Local history folder over 10GB after few hours of usage.

Hi my local history folder went up to 10GB when i only written just 10 lines code and kept storm in bacground. i have noticed that on magento projects its constantly updating and processing something and slows extremly down (lags sometimes for few seconds) (latest ubuntu, latest stom, oracle jdk 8, i7-6700hq 2.7ghz 4c 8t, 8gig ram, samsung nvme 128gb). some serious bug seems to be here. if help i am using also magicineto extension. also that bug happnes randomly, not always so it looks like something triggers it.

 https://postimg.org/image/7f9jtnkc7/

thank you

 

 

7 comments
Comment actions Permalink

Hello Erik,

If you disable Magicento plugin (and other 3rd-party plugins if any), does the behavior normalize?

0
Comment actions Permalink

I will try to not use it when working on magento projects. An i will let you know over this week. But i can tell now that with 2016.1 version of phpstorm it does not happend.

0
Comment actions Permalink

https://www.wetransfer.com/downloads/797de011f79912f258beba9c70afb49420160727070828/5d8da9407949404060cc8372366dc6cc20160727070828/00febe

 

i have noticed about an "java_error_in_PHPSTORM.hprof" which has 85.7MB and created when the "bug" occured

0
Comment actions Permalink

Could you please switch to the JetBrains JDK instead of Oracle?
You can get it here: https://bintray.com/jetbrains/intellij-jdk/

0
Comment actions Permalink

Ok

1. i have downloaded "jbsdk8u76b218_linux_x64.tar.gz"

1.2 checked phpstorm.sh

# ---------------------------------------------------------------------
# Locate a JDK installation directory which will be used to run the IDE.
# Try (in order): PHPSTORM_JDK, ../jre, JDK_HOME, JAVA_HOME, "java" in PATH.
# ---------------------------------------------------------------------

2. backed up the old JRE folder in phpstorm install diretory (Side note: it was the original, from php storm install, i didn't knew until now that phpstorm ships with jre, so i think that phpstorm never used oraclejdk that was installed from ppa)

3. replaced it with the JRE inside tar.gz i have downloaded.

4. launched phpstorm.

Maybe it's just placebo effect, but phpstorm feels to be faster (startup and project load)

 

Today this bug not happend so cant tell for now if anything (disabling magiciento or replacing jre) fixed the problem

0
Comment actions Permalink

Thanks for the update.

You can try bringing the plugins back in and check the behavior.

By any chance, do you have any symlinks in your project structure?

0
Comment actions Permalink

no, i do not have symlinks as far i know. still bug does ot apperad again. so cant tell now

0

Please sign in to leave a comment.