Datagrip Clipboard to Excel

Answered

When I copy Datagrip contents to my clipboard and paste to excel, all values get pasted to one column with comma separation.  Is there a way to format clipboard contents so they go into individual columns?  Otherwise I have to do text to columns in excel every time.

Also, tangentially related-- I am unable to export contents to csv in utf-8.  I export Japanese characters often and seemingly the only way to get utf representation is through copying to clipboard.

5 comments
Comment actions Permalink

Choose HTML (js) as the extractor instead of CSV, then you can copy and paste the result set into Excel or Google Sheets.

1
Comment actions Permalink

Hello Andrew,

You can configure different separator for the extractor when copying content to the clipboard in Configure CVS Formats... dialog.

About encoding issue: please check Encoding Settings https://www.jetbrains.com/dbe/help/file-encodings.html for the project. The project encoding set there should work.

0
Comment actions Permalink

How does that help, you didn't answer the question.

 

0
Comment actions Permalink

The issue here isn't DataGrip but how Excel treats CSV/TSV when pasting to a sheet.  It only knows you want that data in separate columns if you previously did a text to columns and identified the separator for your spreadsheet.

You can right-click on a query and select 'Execute to a File'.  In the next window, you can then select Excel XLSX.

0
Comment actions Permalink

Jon Crowell Yesterday you revived a dead post with a perfect solution to the problem that I had today. Thank you for your solution and amazing timeliness :)

0

Please sign in to leave a comment.