Disable PHP HEREDOC SQL query hover pop-ups

Answered

I have SQL in a HEREDOC in a .php file that whenever I hover over it or move the mouse it pops up these stupid warnings saying "No data sources are configured to run this SQL" or "SQL dialect is not configured"...

It would be nice to configure these things but I may not have time or want to so I just want to disable these pop-ups or specific warnings, as it pops up whenever I move the mouse to click to start typing and is making it almost impossible to edit the code.

https://imgur.com/chHSlv6

5 comments

Hi there,

1) It's nothing to do with HEREDOCS -- the same would be in ordinary string as long as IDE can detect that it's a SQL code there

2) "Settings/Preferences | Editor | Inspections | SQL" -- disable any unwanted inspections there.

0

Do those error names match the pop-up in the header (of the pop-up) or the error message? I notice these ones do but not completely.

0

Also it would be better if the messages didn't pop up over the code, I'd prefer an icon somewhere else activate that I can click, or the message header show in a bar somewhere not in the way.

0

Thanks, got your point. There's an existing feature request: https://youtrack.jetbrains.com/issue/IDEA-114803 but as I can see you're already aware of it. Issues/features are addressed/implemented based on their vote weight so the only suggestion here - is to add more votes to a beforementioned request.

 

 

0

I didn't know those were the same thing, but they're just as annoying.

0

Please sign in to leave a comment.