Gradle dependencies not updated for Kotlin 1.0

I am using the latest version of IDEA 15.0.4 Build #IU-143.2287.

If I create a new Gradle project and select "Kotlin (Java)", the build.gradle file it generated has the following dependencies:

classpath "org.jetbrains.kotlin:kotlin-gradle-plugin:1.0.0-release-IJ143-75"
compile "org.jetbrains.kotlin:kotlin-stdlib:1.0.0-release-IJ143-75"

and I will get the error that they cannot be found.

With the release of Kotlin 1.0, they should be corrected to the following:

classpath "org.jetbrains.kotlin:kotlin-gradle-plugin:1.0.0"
compile "org.jetbrains.kotlin:kotlin-stdlib:1.0.0"

 

 

 
1 comment
Official comment

Thanks for your report! This issue is already fixed, and the fix will be included in Kotlin 1.0.1.

Please sign in to leave a comment.