PHP storm server randomly fails to server html files

Often when I open an html file in the editor and click the open in chrome button it load fine in chrome. But every now and then all I get is a page like so: any ideas? 

The requested URL could not be retrieved


The following error was encountered while trying to retrieve the URL: http://localhost:63342/****

Connection to ::1 failed.

The system returned: (111) Connection refused

The remote host or network may be down. Please try the request again.

2 comments

Hi there,

Looks like you local specific issue.

>Connection to ::1 failed

::1 is IPv6 (localhost in IPv4 = 127.0.0.1; in IPv6 = ::1) -- maybe check your network settings. Can also check your code -- maybe it has such reference in it

>Your cache administrator is *********

Please check who that guy is. If you hover over the link it has reference to ********** domain; contains your gmail email address etc

I suggest:

  1. Check your antivirus/internet security settings
  2. Check your proxy settings (in both OS/Chrome as well as in PhpStorm)
  3. Check your ad blockers (be it browser extension or some transparent proxy/internet security software)
  4. Try another browser -- maybe you have some faulty/bad extensions (disable them all for a test)

 

0

BTW:

  • requested URL that failed was  /*****/index.html
  • request was made to localhost:63342 (should be served by PhpStorm's built-in web server). based on the error it looks like request was done using IPv6 instead of IPv4
  • check your "hosts" file -- see if removing this kind of line from there helps (::1   localhost)
  • if you are on Mac -- try giving IPv4 a priority over IPv6

 

0

Please sign in to leave a comment.