Now way to completely turn off formatting?

I've been using the CLion 2016 the last week on both my Ubuntu and Lubuntu machines.  I like it a lot, except for the reformatting.  I've searched all through the settings multiple times, tweaked the editor settings A LOT, searched the forum, Googled and it seems there's no way to completely turn it off.  Is that right?  One thing that is driving me nuts is that I like my class headers declarations to look like this:

 

class Foo

{

   public:

      Foo();

      virtual ~Foo();

      // etc

};

 

If I happen to put a constructor definition as follows it will automatically move the open brace back to the column of "public" as noted below.  Drives me nuts and have not found a way to turn it off:

 

class Foo

{

   public:

      Foo()

      {   // <--- Will automatically move it back one tab stop

 

2 comments
Comment actions Permalink

You can setting Code style - File / Settings / Editor / Code Style in "Wrapping and Braces" tab have options "Braces placement", and there you can customize it.

0
Comment actions Permalink

Thanks!  Between that and the indentation settings I was able to get it to work how I want.

0

Please sign in to leave a comment.