PhpStorm being slow lately

I've been using PhpStorm for a little over 3 months and it's being working great, but starting today it has been REALLY slow at a point where it takes about 2-3 seconds for a keyboard key to respond.

This weekend I've upgraded my computer's Java, not sure if this caused this problem.

 

This is my Performance Summary Report:

 

Filesystem Info:
File system is case sensitive: false
Are there symlinks: true
Number of files: 95218

System Info:
Number of CPU: 8
Used memory: 474Mb
Free memory: 250Mb
Total memory: 725Mb
Maximum available memory: 725Mb

Project Info:
Number of opened files: 7
File size (in lines): 42
File size in characters: 1796
Last action: _Undo Backspace
Number of injection: 0

IDE Info:
Custom plugins: [BashSupport (1.5.5.143), Markdown support (8.0.0.20151209), Lines Sorter (1.0.1)]
Disabled plugins:[Time Tracking (1.0)]
Build version: PhpStorm 10.0.3 Build #PS-143.1770 January 8, 2016
Java version: 1.8.0_40-release-b119x86_64
Operating System: Mac OS X (10.11.6, x86_64)
JVM version: OpenJDK 64-Bit Server VM JetBrains s.r.o
6 comments
Avatar
Vladimir Luchansky
Comment actions Permalink

Hello,

Not sure if you are using the old version on purpose but there is PhpStorm 10.0.4 at here.

Did you try to run File > Invalidate Caches/Restart > Invalidate and Restart? This may help.

Also the latest version available at http://www.oracle.com/technetwork/java/javase/downloads/jdk8-downloads-2133151.html is 1.8.0_101 while you have 1.8.0_40 which is relatively old.

But we would recommend to use JetBrains version of SDK available at https://bintray.com/jetbrains/intellij-jdk/download_file?file_path=jbsdk8u112b255_osx_x64.tar.gz - just unpack the archive, place the folder into some safe place like ~/Applications instead of Downloads and in PhpStorm run Cmd+Shift+A > Switch IDE Boot JDK, then point it to the custom jdk location.

0
Comment actions Permalink

Thanks Vladimir.

I upgraded PhpStorm to 10.0.4. This was another issue I had before where the update didn't happen automatically due to permission issues.

I haven't coded long time yet to say it's fixed, but I'm having an issue with the custom SDK you provided: when I press Cdm+Shift+A > Switch IDE Boot JDK, nothing happens. I tried this before the upgrade and a popup window opened, but there was no option to select a custom JDK. Now, after the upgrade, no popup opens. :( 

Now these are my info after the upgrades:

IDE Info:
Custom plugins: [BashSupport (1.5.8.143), Markdown support (2016.1.20160405.143), Lines Sorter (1.0.1)]
Disabled plugins:[Time Tracking (1.0)]
Build version: PhpStorm 10.0.4 Build #PS-143.2370 April 29, 2016
Java version: 1.6.0_65-b14-468-11M4833x86_64
Operating System: Mac OS X (10.11.6, x86_64)
JVM version: Java HotSpot(TM) 64-Bit Server VM Apple Inc.

It looks like I went back to an older Java version?

0
Avatar
Vladimir Luchansky
Comment actions Permalink

Please try to follow the Mac OS part for this article, jdk file in particular: https://intellij-support.jetbrains.com/hc/en-us/articles/206544879.

Java 6 is, of course, not recommended. Wondering how it was possible to run under it. Did you download and install a version without bundled JDK? If yes then it is not right and you should've use http://download.jetbrains.com/webide/PhpStorm-10.0.4-custom-jdk-bundled.dmg file.

0
Comment actions Permalink

I downloaded the 2016.2 version and was able to get Java back to 1.8.0_76 . I'm going to use it today and see if it's better.

I downloaded it by going to this page: https://www.jetbrains.com/phpstorm/download/ . Is it a version without a bundled JDK? Also, what's the difference between 10.0.4 and 2016.2? It seems that there was a change in the version number format?

Thanks for all your help so far.

0
Comment actions Permalink

It's the one with bundled JDK. Yea, there was a change in format. After 10.0.4 goes 2016.1 then 2016.2. Changes were not really significant there + java 6 is no longer supported starting 10.0.4 and after.

0
Comment actions Permalink

Thanks, the slowness issue seems to be gone with the latest version. Thanks for all your help.

0

Please sign in to leave a comment.