First time install

Hi, I'm running Opensuse Tumbleweed. Keep getting this error message each time attempt to run pycharm.sh

Java appears OK.
kdog@TW133:~/pytools/pycharm-community-5.0.4/bin> java -version
openjdk version "1.8.0_72"
OpenJDK Runtime Environment (build 1.8.0_72-b15)
OpenJDK 64-Bit Server VM (build 25.72-b15, mixed mode)
HERE pycharm.sh just dies.

kdog@TW133:~/pytools/pycharm-community-5.0.4/bin> ./pycharm.sh
java version "1.5.0"
gij (GNU libgcj) version 5.3.1 20151207 [gcc-5-branch revision 231355]

Copyright (C) 2007 Free Software Foundation, Inc.
This is free software; see the source for copying conditions. There is NO
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

Start Failed: Internal error. Please report to http://jb.gg/ide/critical-startup-errors

java.lang.IllegalArgumentException: URI "file:./../lib/bootstrap.jar" is not hierarchical
at java.io.File.<init>(libgcj.so.16)
at com.intellij.ide.BootstrapClassLoaderUtil.urlToPath(BootstrapClassLoaderUtil.java:121)
at com.intellij.ide.BootstrapClassLoaderUtil.addParentClasspath(BootstrapClassLoaderUtil.java:102)
at com.intellij.ide.BootstrapClassLoaderUtil.initClassLoader(BootstrapClassLoaderUtil.java:55)
at com.intellij.ide.Bootstrap.main(Bootstrap.java:32)
at com.intellij.idea.Main.main(Main.java:91)


Also, an UI exception occurred on attempt to show above message:
java.lang.NoClassDefFoundError: javax.swing.UIManager
at java.lang.Class.initializeClass(libgcj.so.16)
at javax.swing.UIManager.getUI(libgcj.so.16)
at javax.swing.text.JTextComponent.updateUI(libgcj.so.16)
at javax.swing.text.JTextComponent.<init>(libgcj.so.16)

Please sign in to leave a comment.