phpstorm Symgony annotations and Angular2 template code assistance not working



I was using phpstorm to work on a symfony project for a couple of months now with 0 problems so far. A while back i updated and suddenly i stop getting code assistance when using annotations (ie. @Routes wouldn't auto complete the "name" property or @ORM\OneToMany wouldn't not ask me for the "targetEntity"). Also the use for the annotation would also warn me it that the class was not in use(It was greyed and squigly underlined). WIt really didn't affect my work so i just kept working with little to no trouble.

Now I updated to 2016.1 today hoping it would fix the issues and also get the angular2  support (assistance for event and property bindings, etc.. on template strings)  which wasn't working for me either. This didn't solved a thing.

Have anyone else had this issue as well or did i just messed up something in the settings panel or dont have a pluggin install? (i do have the symfony plugin and i had an angularjs one as well from the repositories).


Thanks in advance.


Comment actions Permalink
Official comment



Please try to install PHP Annotations plugin. If something is still not working after that please send us detailed steps we can use to reproduce an issue.

Comment actions Permalink



Thank you, downloading the plugin fixed the issues with symfony and angular2 code assistance also started to work after a clean re-install.


Please sign in to leave a comment.