Problem with ftp sync.

Hi,

My project uses sync through ftp. All works fine, but recently the project moved to a new server
and sync through FTP does not work correctly. But simple FTP works fine on phpstorm, filezilla, totalcommander.


I enable debug log "com.jetbrains.plugins.webDeployment". The log shows that client try to
execute ftp command "MDTM" with dir "MDTM laravel/app/storage/cache, MDTM
laravel/app/storage/logs" etc.


Why does it happen?

Thank you.

log file: idea.log

4 comments

Hi there,

Please try enabling "Always use LIST command" option under "Advanced options..." of your FTP deployment entry (Settings/Preferences | Build, Execution, Deployment | Deployment)

MDTM should be used on files .. and IDE tries to use it for directories (which does not make much sense as not every FTP server supports such date for folders).

As for me -- you can file a ticket to the Issue Tracker at https://youtrack.jetbrains.com/issues/WI

1

Hi,

 

Is there an option to enable MFMT on FTP server? PhpStorm would try MFMT first, then it would go for MDTM.

0
 
Thank you for the quick reply.
 
I used "Always use LIST command" option before and result was the same.
 
MFMT is enabled on FTP server according to log, isn't it?
 
0

Infortunately currently there is no setting to avoid asking MDTM on directories. That shouldn't happen, and I've created the issue. But for items which fail to provide MDTM timestamp from listing command is used. So what issues do you experience?

0

Please sign in to leave a comment.