Error launching IDEA (JAVA_HOME)

Answered

Windows 7
IDEA ideaIU-2016.1

Basic question I hope. I'm using the latest version of Intellij, and have the latest 64b version of the the Java JDK/JRE that I've set as my JAVA_HOME root.
Running the Intellij IDEA 1016.1(64) launch shortcut ("C:\Program Files (x86)\JetBrains\IntelliJ IDEA 2016.1\bin\idea64.exe") results in:

Error launching IDEA
The environment variable JAVA_HOME (with the vale of <valid path to my JDK v8 install>)
does not point to a valid JVM installation.

I've also tried changing my JAVA_HOME to the JRE location of this as well, still no go.

Is it expecting a 32b version of the JDK ? JRE?

Interesting, so if start Intellij using the idea.exe executable it works fine.

I'm confused. Can someone help unwind this?

 

thanks,
Karl 

3 comments

See https://intellij-support.jetbrains.com/hc/articles/206544879 .

To run idea64.exe you need to have 64-bit JDK 8 installed. IDEA should be able to detect it automatically from the registry.

0

I am the exact same problem but Java is defined Idea crashed and ever since I'm not able to activate it  - I am using the paid version!

0

with same problem , I found 2 solution ! depend on situation

1: first of all check java path under computer-property -advance setting-veriable environment: delete java_home.

2: remove all temp file after installing pyCharm then run it again.

0

Please sign in to leave a comment.