IntelliJ 2016.1 GWT dev mode launc

Answered

IntelliJ IDEA 2016.1
Build #IU-145.258, built on March 17, 2016
JRE: 1.8.0_40-release-b132 x86_64
JVM: OpenJDK 64-Bit Server VM by JetBrains s.r.o

 

 

Hi,

Can anyone please let me know what is the intelliJ doing when it shows the following progress dialog? I see that it is deleting my already present 'war' folder under my GWT module and it is replacing it with IntelliJ created one. What i want is that it should merge instead of replace. Is there a way i can configure that?

14 comments

Hello,

this is the process of copying of static resources. Default destination folder is "<idea_installation_dir>/system/gwt/<project_name.hash>/<module_name.hash>/run/www", but it can be changed by adding "-war <custom_dir>" in "Dev Mode parameters" field in "Run/Debug Configurations" dialog.

Destination folder is synchronized with all the static resources of your project + compiled code and resources generated by GWT compiler. It copies/deletes only changed files and folders so the process should be pretty fast. This won't happen only if "-noserver" DevMode parameter presents in "Dev Mode parameters" field.

You could find your current directory by looking at log messages when you start you GWT application. It has to follow "-launcherDir" parameter in line that starts with "Runing CodeServer with parameters:". Could you please reply me with this folder path? Then we will discuss your second question as well. Thank you!

 

0

Hi,

Thanks for the reply.

I do need to specify the -war parameter in the GWT Dev Mode paramater. However i expect IntellIJ to merge all static resources of my project(present under the war i specify with -war parameter) + compiled code and resources generated by GWT compiler. Which was being done in IntelliJ 12. However in IntelliJ 15 it is replacing instead of merging. I need help in changing this behavior.

I will answer to your question about the '-launcherDir'  in few hours. I do not have access to my project right now.

 

0

Hi,

 

I dont see any -launcherDir or "Running CodeServer with parameters" when i invoke the GWT Application.

0

I am facing the same issue and would like IntelliJ for GWT to work like it used to work in IntelliJ 12.

0

 

 

 

 

 

 

Before GWT Dev Mode

 

After running GWT Dev MOde

 

 

0

Hi,

am I right that "war" directory of your project is used as "-war" DevMode parameter of your application? If so, then you may need to reconfigure your project.

Please take a look at this issue: https://youtrack.jetbrains.com/issue/IDEA-150142
Is it relevant to what you have? Could you please also attach screenshot of your Run/Debug configuration?

Thank you!

0

The issue i face seem to be similar to the one in https://youtrack.jetbrains.com/issue/IDEA-150142.

However i cannot do -noServer option as i want the wars to be merged.

if i provide -noServer intelliJ doesnt even run the server.

GWT Module to load: com.usm.usm

VM Options: -Xms1024m -Xmx2024m -XX:MaxPermSize=1024m -XstartOnFirstThread

Dev Mode Parameters: -startupUrl UM.jsp -war /Users/sganta/workspace/integ/ims/src/binaries/usm/war/ -logLevel DEBUG -codeServerPort auto -port auto -bindAddress localhost com.usm.usm com.usm.usm_usm_default_gecko1_8

JRE: 1.7

Open in browser: Firefox.

 

0

This line is the case: "-war /Users/sganta/workspace/integ/ims/src/binaries/usm/war/"

IDEA of versions before 2016 passed two "-war" parameters in this case, and further behavior was undefined. This was fixed in issue https://youtrack.jetbrains.com/issue/IDEA-150142.

As I see you use "/Users/sganta/workspace/integ/ims/src/binaries/usm/war/" directory to store static resources, right? In this case you should change "-war" parameter to the other directory that will be managed by IDEA. You could even remove this parameter and IDEA will create its own directory for your project. Files from that directory will be automatically synchronized with your project's files on every start (except the case when "-noserver" option is used).

Please confirm that you don't have any problem when you change "-war" parameter. Thank you!

0

The problem still remains.

When i remove the -war option GWT created GWT compiled output at /Users/sganta/Library/Caches/IntelliJIdea2016.1/gwt/ddd.bcf7fd7b/ddd.e34195f7/run/www 

However it did not have the static resources i have in my "war" folder of the project.

0

Correction

When i remove the -war option IntelliJ created GWT compiled output

0

- However it did not have the static resources i have in my "war" folder of the project.

There might be a problem in your project's configuration. Could you please check "Web" Facet configuration of your project? Your "war" directory has to be there as "Web Resource Directory":



0

Hi Ivan,

I have the similar Web Facet but still it is replacing.

0

Hi,

Finally i got this working :)

I had to create a seperate WebResources directory and put my Project Static resources there :)

It was a good learning experience.

 

Thanks Ivan for your help.

0

Thank you, I'm glad that we figured everything out!

0

Please sign in to leave a comment.