Disabling shortcut "alt+g" not mentioned in the keymap

Hi,

On OSX I'm using the default keymap and I found out a shortcut which is not mentioned in the keymap. The shortcut is:

alt+g

and when a search toolbar/window is open, it (un)checks the "regex" checkbox. Is there a way to disable this? Either in IDE or in the OS?

Thank you!

4 comments
Comment actions Permalink

Hi there,

It's a standard mnemonics (shortcut) behaviour. When you press "Alt" button the speed letter (shortcut) should be underlined (sorry, not 100% sure how exactly it looks on Mac since I'm a Windows user and here such letters are underlined by default)

On in-place search bar it would be:

  • Alt+G for triggering "Regex" option
  • Alt+C for "Match Case"
  • Alt+R for "Words"

 

You can disable such behaviour .. but it will affect all other places as well, not just this one.

Settings/Preferences | Appearance & Behavior | Appearance --> Disable mnemonics in ...

(HINT: just search for "mnem" in Settings/Preferences screen using search box)

0
Comment actions Permalink

Thank you, Andriy!

0
Comment actions Permalink

This is actually an important issue. In fact using a Swiss Keyboard layout on a MacBook Pro, the Alt+G is linked to the "@" character.

Having Alt+G to as shortcut to check/uncheck Regex option on a search bar prevented to type the @ character if any view or split-view had the search bar visible. 

The same annoying behaviour is also found in Android Studio.

0

Please sign in to leave a comment.