Working with PHP 4

Hi,

I have to work for the next time on a PHP 4 Project.

Some Questions:

1. Is it possible (easy possible :-)) to have Inspections for PHP 4?
2. The Project has some PHP4 parts (most of them), and some Directories have to be PHP 5 - is ist possible to switch Inspection automaticliy (maybe is there a scope - based Inspection?)

3. I have turned on XDEBUG on a local XAMPP (1.6.1 - PHP 4.4.6) - but PHPStorm does not work with xdebug. On PHP5 - Projects, this is no problem. Does anybody know, if it should work with PHPStorm (or IntelliJ) - and maybe how?

Thank you very much.

By the way: it would be very good, if PHPStorm would support PHP 4 oder PHP 5.0 . In my Company there are tones of old code :-)

I'm using IntelliJ 2016.1 (and PHPStorm 2016.1 sometimes)

 

 

1 comment
Comment actions Permalink

Hi there,

PhpStorm supports PHP 5.3 and newer only. Even 5.2 specific features are not supported (I mean: you cannot set PHP Language Level to be 5.2 (there is simply no such option) so that 5.3+ features would be marked with warnings).

PhpStorm will not be supporting PHP 4 for sure (which is not supported for a long time by PHP/Zend).

To answer your questions:

  1. No
  2. No -- PHP Language Level is done on per-project/interpreter level -- such setting cannot be controlled via custom scope unfortunately.
  3. No idea here
0

Please sign in to leave a comment.