WebStorm - Auto formatting to 4 instead of 2 space indents

Hello,

I'm seeing something odd in that my indents are set at 2 spaces

but that is not being obeyed in this following situation

The above if block auto indents to 4 spaces. I am seeing this in both WebStorm 11 and 2016.1 which leads me to believe that is is one a settings issue as opposed to an application bug. Would anybody know which setting I need to set to prevent the 4 space indent and instead set this to 2?

My thanks in advance for any help or hints!

 

Please sign in to leave a comment.