IDEA 2016.1 Can't load AMD 64-bit Oracle OCI dll on a IA 32-bit platform (which in fact is 64-bit)

Answered

Hello,

Could you please comment my problem with the Oracle db connection under IDEA 2016.1? Details:

I switched from IDEA 12.1 to 2016.1; the machine, OS (Windows 7 64-bit), JRE 1.8 and Oracle 64-bit driver remain the same.
Before I could connect to Oracle db server using the IDE Database tab. Now using the same connection string for IDEA 2016.1 I receive the warning:

Native library cannot be loaded.
C:\oracle\ocijdbc12.dll: Can't load AMD 64-bit .dll on a IA 32-bit platform

2 comments

Try starting IDEA with idea64.exe instead of idea.exe.

2

Please sign in to leave a comment.