unhide columns in Table Editor?

Im using DataGrip for Mac OSX and it seems awesome except for one dealbreaker. I can't seem to unhide the last column for any table I view in the Table Editor.  Even if I click the blue gear in the top right corner of the editor and click reset view, I still can't seem to see the last column.  If I right click the column bar in the editor and click Column List, the last column always has a strikethrough.  If I hide other columns and click reset view, all come back except for the last one. I'm connecting to a Redshift postgresql database. This is pretty frustrating. 

 

11 comments

Hello Zach,

Actually, Reset view action should work: after it you should see all the columns for the table. And when opening it after. Doesn't it work this way?

What text does DDL tab for the table show? Are there any errors/warnings appear? What do you see for the same table in Database tool window (View | Tool Windows | Database)? Could you please also attach Test Connection results for the data source and idea.log. Thanks.

4

Hi Andrey, 

Thanks for your reply. The Reset view action is definitely not working properly. I can hide all the visible columns, then click Reset View and they all come back except for the last column. 

 

Here is the DDL:

I created a test_column just to confirm the error. Test_column now has a strike through and isn't visible even after clicking reset view:

 

Here is the view in the Database tool window:

The test column is not visible here either. 

 

For the test connection, I'm getting a connection error which is strange because I can definitely connect to my redshift database.  However, I did download my own jdbc drivers from AWS's website. 

I'm using custom URL to connect:

 

 

Im not sure how to attach the idea.log

 

0

>Here is the view in the Database tool window:

>

>The test column is not visible here either. 

One the screenshot I see "test_column" is present. Please clarify.

>For the test connection, I'm getting a connection error which is strange because I can definitely connect to my redshift database.

This is strange as if you are able to connect using this exact Data Source Test Connection should work. Issue could be that the  Data Source is not properly configured.Please double check what driver do you have selected for the Data Source connection you use. Note that is you select Postgres Data Source type - DataGrip will use pre-defined jdbc driver for it. If you are using custom jdbc driver, you should create custom data source (use File | Data Sources... and choose Driver and Data Source option to create new data source:

Select appropriate class in Driver Settings and use it for connection.

>Im not sure how to attach the idea.log

Please post here or upload at any file share server or at our public FTP server 

1

Hi Andrey,

 

Sorry for the confusion on the Database Tool window screenshot. This test column IS visible there. However, it's still not visible on the Table Editor view.  And if I right click and click Column List, it is still strikethrough.

 

I was able to fix the connection issue. For some reason the class field here had switched back to 'org.postgresql.Driver'. I switched it back to what you see below and the connection issue went away. This could be another issue because I havent messed with the connection settings since the initial set up.

 

 



 

0

What do you see if browse table columns in Database Console results tab

How did you create the Data Source for the database (used existing one for PostgreSQL or created via Driver and Data Source action for custom driver connections)?

Does it help to create new Data Source, invoke Synchronize action and check?

0

Hi Andrey,

 

I've found a solution but it's a little weird. I go into the Database Console view and right click the columns header to show the Columns List. I then highlight the strikethrough column by Right Clicking and then pressing space to unhide it. The test column now shows up as unhidden which is great. 

 

The only problem is that if I close the Database Console and reopen it, it's hidden again. Also, if I click reset view it becomes hidden again. This is slightly annoying and definitely a bug but at least I can now see my all of my columns now. 

2

Thank you for the update. Could you check if re-creating data source helps? Also please clarify how are you creating the Data Source. Thanks. Also access to the logs is restricted, could you open the access? Thanks.

0

Andrey, recreating the data source did not help. I did not use the default postgresql driver. I'm using Amazon Redshift jdbc 4.1 driver created using the Driver and Data Source action.  I was just looking at the driver details and Datagrip again switched back to the default Class of 'org.postgresql.driver'.  Weird. I switched it back to 'com.amazon.redshift.jdbc41.driver' and my test connection works properly. 

 

0

Thank you for information. I've created the https://youtrack.jetbrains.com/issue/DBE-2532 issue. Please follow it for updates.

0

Please sign in to leave a comment.