My tab setting keeps getting ignored =(

I am so confused using webstorm.

I want tabs to be 4 spaces and I want tab characters only.

How do I do that? When i change my setting to User tab charater and tab size = 4. 

When I tab I still get 2 spaces.. This is so frustrating -___-

3 comments

Hi there,

Do you have .editorconfig file in your project? Settings from there will override your settings from Code Style you have set in IDE (the whole nature of such files).

Or maybe you have "Detect and use existing file indents for editing" option enabled? If existing file uses 2 space intends then IDE should honour them in this file.

In any case -- as far as I know 2016.1 version should notify you about any of this

0

@Andriy

 

Thank you ! the first case isexactly what is happening to me =) took some time to find out haha

0

Please sign in to leave a comment.