Dart - Could not find a file named "pubspec.yaml"

Hi,

I have started recently with Dart in WebStorm. Everything was OK until I upgraded to 2016.1.1.

Now I am not able to run or debug Dart programs. The result always is: Could not find a file named "pubspec.yaml" in "C:\Users\petrm\Documents".

When I run "pub" commands from the command line, it works fine. It seems that problem is with setting the project root directory.

Thanks for any help,

Petr

2 comments

Hmm... Looks similar to https://youtrack.jetbrains.com/issue/WEB-20844, but it's fixed in 2016.1.1... What run configuration did you try?

0

Hi Elena, 

I run common Javascript Debug configuration. I have tried to run Webestorm in a different profile and everything was working well.

So I have tried to uninstall Webstorm, cleaning up registers and configuration files but without any positive result. I may not have deleted all important files or registers.

0

Please sign in to leave a comment.