Paste doesn't work if copied content has been deleted

I was really surprised about this!

When you copy some content, then later delete the original, then go to paste, you get nothing.

Cutting and pasting works, but it seems as if when you go to paste, PHPStorm needs to somehow reference the original text.


I'd call this a bug!

7 comments
Comment actions Permalink

can't recreate. Please can you provide steps to repeat?

0
Comment actions Permalink

Hi Elena,

Sorry for the delay - I didn't get any update.

Sure, just copy some text, do some other work, move files, overwrite things, etc, then later, paste it back in.

I can't reproduce it now either, but it happens several times a day for me now. I have to end up undoing 20 - 30 times to get back to the state of the file before copying the text, then copying the text, pasting it to text edit, then redoing the 20 -30 changes, then copying and pasting from text edit again.

It's never fun :(

0
Comment actions Permalink

are you sure that it is related to the fact that the text has been deleted? Or, paste just stops working at all? may be related to https://youtrack.jetbrains.com/issue/IDEA-143603 that is caused by libwinpty.dll (library used by built-in terminal) bug

0
Comment actions Permalink

Hi Elena,

I'm working on a Mac at the moment, so possibly not.

I'll see if I can find some way to reproduce it, then if possible video it like the other post.

As yet, it just seems to be after a reasonable amount of other operations, perhaps 10 or so.

Is there a way to show the clipboard history without a modal dialog?

 

0
Comment actions Permalink

Do you use "paste', or 'Paste from history'? Are there any external clipboard managers being used?

0
Comment actions Permalink

Hi Elena,

Nope, just the standard mac and phpstorm setup. I pretty much only do development on this machine.

0
Comment actions Permalink

No ideas then... Screencast plus idea.log might be helpful

0

Please sign in to leave a comment.