Changed A Setting On PyCharm And Now It Won't Open

I was creating a program and I then decided to change the settings to my liking (I didn't change much) and then PyCharm closed suddenly with no error messages or files placed meaning that I don't know what has happened. I have tried running as Admin, running in compatibility mode for Win 8, 7, and XP but they still didn't result in any change. I have also tried reinstalling PyCharm onto my system, that has made zero change too.

I feel that it would be because of the settings I changed that won't let it run, but I don't know where they are stored, so I can't remove that or change it.

If you know a way that I could change or delete it to fix the issue that would be quite good, any other suggestions to fix the problem are welcome too.


I'm having a similar issue. I was running out of alloctable memory for Pycharm based on java options, so pycharm popped up a window wanting to let me change my jmin and jmax. After changing them (and re-installing) I still can't get pycharm to reopen. 


Same issue here, I tried to use "Everything" tool to search for "vmoptions" file, and found in C:/Users/<myusername>/.PyCharm2016.2 . I deleted it and everything is ok now.


Not sure why I put this up ages ago and only now nearly a year on I get replies, but thank you guys however the issue was long resolved, however I didn't fix it on my other drive so if I ever need to use it again I'll use your advice, thanks again


Please sign in to leave a comment.