Unable to use Debugger with Rubymine 2016.1

Hello All,

I installed Rubymine 2016.1 on a Windows 7 (64 bit)  computer with the with Ruby 2.3.1 (x64) release (from today) and RubyDevkit for use with Ruby 2.0 and above (x64) Devkit-mingw64-64.4.7.2-20130224-1432-sfx.exe.

I also performed the Devkit install and configure steps AND adding proper PATHs to my desktop.

The issue is when I run my test application from Ruby it works fine...but if I want to use DEBUG Rubymine indicates it needs to install bunch of gems, and I also install all Runtime dependencies to other GEMS..(so all needed gems are suppose to be installed).  However, I see the following:

Unable to resolve dependency: user requested debase() 0.......

Note that some of the needed gems appear to be installed....

As a second part of this question, what is the best install order....I started by installing Ruby first, then DEVKIT and Then Rubymine....

 

Thank you so much in advance.

 

BTW, I am a novice Rubiest and novice Rubymine user.

 

 

3 comments

Hello, Murat,

sorry for the delay. Could you please specify what happens when you choose to debug a ruby file and agree to install debug gems? Please attach the full output from the Terminal.

0

Hi Olga, 

When trying to debug a ruby file with Rubymine and accept the installation of the missing debase gem I get the following. I've got 'ruby 2.3.1p112 (2016-04-26 revision 54768) [x64-mingw32]':

Following gems were not installed:
C:\Program Files (x86)\JetBrains\RubyMine 2016.2.5\rb\gems\debase-0.2.2.beta8.gem: Error installing debase-0.2.2.beta8.gem:
Building native extensions. This could take a while... ERROR: Failed to build gem native extension. C:/Ruby23-x64/bin/ruby.exe extconf.rb checking for vm_core.h... *** extconf.rb failed *** Could not create Makefile due to some reason, probably lack of necessary libraries and/or headers. Check the mkmf.log file for more details. You may need configuration options. Provided configuration options: --with-opt-dir --without-opt-dir --with-opt-include --without-opt-include=${opt-dir}/include --with-opt-lib --without-opt-lib=${opt-dir}/lib --with-make-prog --without-make-prog --srcdir=. --curdir --ruby=C:/Ruby23-x64/bin/$(RUBY_BASE_NAME) --with-ruby-dir --without-ruby-dir --with-ruby-include --without-ruby-include=${ruby-dir}/include --with-ruby-lib --without-ruby-lib=${ruby-dir}/lib C:/Ruby23-x64/lib/ruby/2.3.0/mkmf.rb:456:in `try_do': The compiler failed to generate an executable file. (RuntimeError) You have to install development tools first. from C:/Ruby23-x64/lib/ruby/2.3.0/mkmf.rb:587:in `try_cpp' from C:/Ruby23-x64/lib/ruby/2.3.0/mkmf.rb:1091:in `block in have_header' from C:/Ruby23-x64/lib/ruby/2.3.0/mkmf.rb:942:in `block in checking_for' from C:/Ruby23-x64/lib/ruby/2.3.0/mkmf.rb:350:in `block (2 levels) in postpone' from C:/Ruby23-x64/lib/ruby/2.3.0/mkmf.rb:320:in `open' from C:/Ruby23-x64/lib/ruby/2.3.0/mkmf.rb:350:in `block in postpone' from C:/Ruby23-x64/lib/ruby/2.3.0/mkmf.rb:320:in `open' from C:/Ruby23-x64/lib/ruby/2.3.0/mkmf.rb:346:in `postpone' from C:/Ruby23-x64/lib/ruby/2.3.0/mkmf.rb:941:in `checking_for' from C:/Ruby23-x64/lib/ruby/2.3.0/mkmf.rb:1090:in `have_header' from extconf.rb:31:in `block in ' from C:/Ruby23-x64/lib/ruby/gems/2.3.0/gems/debase-ruby_core_source-0.9.4/lib/debase/ruby_core_source.rb:14:in `create_makefile_with_core' from extconf.rb:47:in `' extconf failed, exit code 1 Gem files will remain installed in C:/Ruby23-x64/lib/ruby/gems/2.3.0/gems/debase-0.2.2.beta8 for inspection. Results logged to C:/Ruby23-x64/lib/ruby/gems/2.3.0/extensions/x64-mingw32/2.3.0/debase-0.2.2.beta8/gem_make.out

Native compilation failed. Please make sure that you have Ruby DevKit installed

 

However, DevKit is installed correctly on my c:\devkit drive, and that's added to my PATH. If I try to run 'gem install debase' from my command line I get:

"

Temporarily enhancing PATH to include DevKit...
Building native extensions. This could take a while...
ERROR: Error installing debase:
ERROR: Failed to build gem native extension.

C:/Ruby23-x64/bin/ruby.exe extconf.rb
checking for vm_core.h... *** extconf.rb failed ***
Could not create Makefile due to some reason, probably lack of necessary
libraries and/or headers. Check the mkmf.log file for more details. You may
need configuration options.

Provided configuration options:
--with-opt-dir
--without-opt-dir
--with-opt-include
--without-opt-include=${opt-dir}/include
--with-opt-lib
--without-opt-lib=${opt-dir}/lib
--with-make-prog
--without-make-prog
--srcdir=.
--curdir
--ruby=C:/Ruby23-x64/bin/$(RUBY_BASE_NAME)
--with-ruby-dir
--without-ruby-dir
--with-ruby-include
--without-ruby-include=${ruby-dir}/include
--with-ruby-lib
--without-ruby-lib=${ruby-dir}/lib
C:/Ruby23-x64/lib/ruby/2.3.0/mkmf.rb:456:in `try_do': The compiler failed to generate an executable file. (RuntimeError)
You have to install development tools first.
from C:/Ruby23-x64/lib/ruby/2.3.0/mkmf.rb:587:in `try_cpp'
from C:/Ruby23-x64/lib/ruby/2.3.0/mkmf.rb:1091:in `block in have_header'
from C:/Ruby23-x64/lib/ruby/2.3.0/mkmf.rb:942:in `block in checking_for'
from C:/Ruby23-x64/lib/ruby/2.3.0/mkmf.rb:350:in `block (2 levels) in postpone'
from C:/Ruby23-x64/lib/ruby/2.3.0/mkmf.rb:320:in `open'
from C:/Ruby23-x64/lib/ruby/2.3.0/mkmf.rb:350:in `block in postpone'
from C:/Ruby23-x64/lib/ruby/2.3.0/mkmf.rb:320:in `open'
from C:/Ruby23-x64/lib/ruby/2.3.0/mkmf.rb:346:in `postpone'
from C:/Ruby23-x64/lib/ruby/2.3.0/mkmf.rb:941:in `checking_for'
from C:/Ruby23-x64/lib/ruby/2.3.0/mkmf.rb:1090:in `have_header'
from extconf.rb:31:in `block in <main>'
from C:/Ruby23-x64/lib/ruby/gems/2.3.0/gems/debase-ruby_core_source-0.9.4/lib/debase/ruby_core_source.rb:14:in `create_makefile_with_core'
from extconf.rb:47:in `<main>'

extconf failed, exit code 1

Gem files will remain installed in C:/Ruby23-x64/lib/ruby/gems/2.3.0/gems/debase-0.2.1 for inspection.
Results logged to C:/Ruby23-x64/lib/ruby/gems/2.3.0/extensions/x64-mingw32/2.3.0/debase-0.2.1/gem_make.out

"

 

 

 

0

Hi, Mickael,

could you please check how it goes in RubyMine 2016.3? In addition, please make sure that you manage to install manually from cmd any other gems that need building native extensions .

0

Please sign in to leave a comment.