When running debugger, there's always a breakpoint in Node core util.js/deprecate()

I just upgraded to Node 4.4.3, I've pointed WebStorm to use the new version. When I run the debugger, it always stops at the Node core module util.js/deprecate. Where it prints what modules have been deprecated. It hits this function about 6 times before it eventually gets to the break point that I want to go to.

I've tried passing --no-deprecate as a node paramter, still get it. I've tried going to the Node Inspections and to only tell me about errors. Still didn't work.

I've tried putting

//noinspection JSDeprecatedSymbols

At the start of my script, that didn't work either.

Any help would be greatly appreciated.

 

 

2 comments

please can you provide a code sample that shows up the issue? Do you have exception breakpoints enabled?

0

Ah, thank you for your help. While, Exception Breakpoints were not enabled, somehow the file mentioned had a breakpoint enabled in util.js

0

Please sign in to leave a comment.