Variable Name Suggestion are too heavy handed as of 2015.

Answered

If I have a class named SomeClassThatDoesSomething and go to declare a reference to it, I used to could type "final SomeClassThatDoesSomething sctds =" and IDEA would let me.

Now there is this infurating "feature" that converts that into someClassThatDoesSomething instead of just taking what I typed in.

How do I disable this completely counter productive behavior.

7 comments

This is about CREATING new reference names not COMPLETION of EXISTING names and that is already disabled still does it. Very frustrating!

Plus I WANT that to work on COMPLETION of EXISTING names, but NOT on CREATION. 

0

Please provide a video of the problem with this option disabled.

0

does not matter what I type, anything other than ESCAPE and it automatically inserts the exact name of the class but in lowerCamelCase, this is very easy to replicate.

IntelliJ IDEA 2016.1.1
Build #IU-145.597, built on March 29, 2016
JRE: 1.8.0_40-release-b132 x86_64
JVM: OpenJDK 64-Bit Server VM by JetBrains s.r.o

I do not have recording software on my machine nor the desire to hunt something down and install it for something that is this easy to replicate.

 

0

Not reproducible with that option disabled.

0
final StringIndexOutOfBoundsException sioobe 

if I type anything other than sioobe it does not auto insert the long name, but if it is the exact set of capitalized letters it auto selects.

0

See https://youtrack.jetbrains.com/issue/IDEA-88179 and the linked issues. If you disable the option shown on my screenshot, it will not select this variant on space and `sioobe` will remain after you press space or =, otherwise you confirm the completion choice that is displayed in the popup. With the option disabled, you will need to press Enter for code completion.

0

Please sign in to leave a comment.