Custom Live templates will not load but in correct folder(templates)

Hi, wondering if anybody can shed some light on why my custom Live templates will not load. The xml is in correct folder(config/templates).

I have reinstalled the latest but still no show. Is there a setting thats saved in the settings.jar or should it just load the files in the config/templates folder?

7 comments

The correct way is to export settings in a .jar archive and then import it. I'll check quickly if moving a template file is also valid solution.

0

Placing .xml in config/templates should be enough. Can you attach this .xml file and your idea.log?

0

Your templates work fine for me:

 

what folder did you place your .xml file in? It should be C:\Users\SteveC\.PhpStorm2016.1\config\templates\

0

yes that folder. They where working thats why i dont understand.

 

0

Just did a fresh install they did showup. Then added my config folder contents that i had backed up, as settings.jar didnt restore them.. Now not showing again.....so the old files are stopping it from showing some how??

0

Whittled it down to "config/settingsRepository" a setting in this folder is causing it. My live templates are back.

0

Please sign in to leave a comment.