Uisng mingw-64 implementation on Windows

I am trying to use CLion 2016.1.1 with mingw-64 gcc/4.9.3. In File | Settings | Toolchain if I specify the mingw32 or mingw64 directory of the 32-bit or 64-bit implementation of mingw-64 gcc/4.9.3 I get the response from CLion of:

MinGW version: w64 5.0

Environment: MinGW-w64: current version is w64 5.0; supported version range is 3.x-4.x

GDB: current version is GNU gdb ( GDB ) 7.9.1; supported version is 7.8.x

What is wrong with CLion ?

 

 

 

4 comments

Hi Edward.

The main reason 5.0 is listed as not supports is GDB 7.9, which has some issues (i.e. https://youtrack.jetbrains.com/issue/CPP-4604). Debugger support is now under active development. Otherwise using MinGW-w64 5.0 should be fine. Sorry for the inconvenience!

0

I am pointing to 4.9.3, not 5.0.

0

MinGW-w64 has kind of confusing version scheme - the dropdown in the MinGW installation is actually the GCC version, and the MinGW-w64 version for GCC 4.9.3 should be 5.0 (it is mentioned via mingw-w64-headers/crt/_mingw_mac.h header file but not in the MinGW documentation).

0

Since CLion does not support any version of mingw-64 what good can it possibly be on Windows ?

0

Please sign in to leave a comment.