Pycharm, Docker and connection refused

I'm an Aldryn user. (http://support.divio.com/hc/en-us/articles/208181815-Set-up-local-development-environment-with-PyCharm)

Also, I'm on Windows 10. But I created an VirtualBox Ubuntu 16.04 machine.
Within that one I installed Pycharm and the Aldryn prerequisites.

Now I'm trying to activate docker 

http://screencast.com/t/O4fwG6IQWus
http://screencast.com/t/Tcb3J1WfYNz

On OK< I get this message:

org.apache.http.conn.HttpHostConnectException: Connect to 127.0.0.1:2376 [/127.0.0.1] failed: Connection refused  (http://screencast.com/t/xtedAcbd)

Is this I pycharm thing, or a Virtualbox problem.

Any further help would be gratefully appreciated.

10 comments
Comment actions Permalink


Same problem, PHPStorm, Windows 10, one year after

1
Comment actions Permalink

Solved. It seems there some BIC in new docker version. Should tick one checkbox in preferences to make it work. (see creenshot)

8
Comment actions Permalink

Would there be a way to establish TLS connections? Checking that box clearly states that it "makes yourself vulnerable to remote code execution attacks"

4
Comment actions Permalink

Replacing tcp:// by https:// in the api url works for me in Webstorm

https://github.com/kubernetes/minikube/issues/580

4
Comment actions Permalink

Holy cow, thank you Alex! It's 2019 and this is still not documented. Once now can point to a certificate folder, but that does not imply TLS!?

1
Comment actions Permalink

Changing tcp:// to https:// in the api url worked for me in Rubymine too. I didn't need to reconfigure docker to expose anything either.

0
Comment actions Permalink

I am having this Docker connection issue with PyCharm (2019.1.1 Professional Edition) running on Windows 10 Pro and Docker desktop for Windows. I am having this issue after either update to Windows or Docker Desktop. I have the following option selected in settings for Docker Desktop.

 

0

Please sign in to leave a comment.