Pycharm, Docker and connection refused

I'm an Aldryn user. (

Also, I'm on Windows 10. But I created an VirtualBox Ubuntu 16.04 machine.
Within that one I installed Pycharm and the Aldryn prerequisites.

Now I'm trying to activate docker

On OK< I get this message:

org.apache.http.conn.HttpHostConnectException: Connect to [/] failed: Connection refused  (

Is this I pycharm thing, or a Virtualbox problem.

Any further help would be gratefully appreciated.


Same problem, PHPStorm, Windows 10, one year after


Solved. It seems there some BIC in new docker version. Should tick one checkbox in preferences to make it work. (see creenshot)


Would there be a way to establish TLS connections? Checking that box clearly states that it "makes yourself vulnerable to remote code execution attacks"


Replacing tcp:// by https:// in the api url works for me in Webstorm


Holy cow, thank you Alex! It's 2019 and this is still not documented. Once now can point to a certificate folder, but that does not imply TLS!?


Changing tcp:// to https:// in the api url worked for me in Rubymine too. I didn't need to reconfigure docker to expose anything either.


I am having this Docker connection issue with PyCharm (2019.1.1 Professional Edition) running on Windows 10 Pro and Docker desktop for Windows. I am having this issue after either update to Windows or Docker Desktop. I have the following option selected in settings for Docker Desktop.



Please sign in to leave a comment.