debug stopping all over the place

Answered

When I enable a breakpoint the application starts pausing other places.  For example - it stops in timer.rb - line 99 - "cancel unless recurring".  This did not occur until one of the recent updates.  Please help.  Breakpoints are one of the many benefits of a complete IDE.

Using -

RubyMine 2016.1.1
Build #RM-145.972, built on May 19, 2016
JRE: 1.8.0_76-release-b162 x86_64
JVM: OpenJDK 64-Bit Server VM by JetBrains s.r.o

 

6 comments
Comment actions Permalink

I have had this problem not only with the current version but also with prior ones (within the last year).

I'm not sure if this was always the case, but in recent versions the problem does not occur when no breakpoints are set. So setting breakpoints after starting the app has been a workaround.

 

 

0
Comment actions Permalink

I have this issue only when debug with RSpec. Enable "Ignore non-project sources" improved the situation but still have several unexpected stops.

Very annoy problem and please fix asap.

0
Comment actions Permalink

I concur as well. I am running the latest update:

RubyMine 2016.1.1
Build #RM-145.972, built on May 19, 2016
JRE: 1.8.0_76-release-b162 x86_64
JVM: OpenJDK 64-Bit Server VM by JetBrains s.r.o

When running RSpec specs, it's not really possible to wait to set the breakpoint until after the app starts. I did try beginning the execution and setting it after a couple of seconds, but once a new breakpoint was set it began stopping on many incorrect lines once again. Even with 'Ignore non-project sources" it's a nightmare since we have a large Rails app with lots of startup configuration.

I really hope this is known and/or a high priority. Back to pry for now...

--Scott

0
Comment actions Permalink

Quick update -- I went to log this as a defect and did find a current outstanding issue already under investigation:

RUBY-17990

More details and potential workarounds are there in the comments, but the problem appears to revolve around debase-0.2.2.beta7. Reports are there that both beta6 and beta8 do not exhibit the problem, but I have not verified.

 

--Scott

0
Comment actions Permalink

I observe same problem with nodejs:

 

IntelliJ IDEA 2018.1.5 (Ultimate Edition)
Build #IU-181.5281.24, built on June 12, 2018
JRE: 1.8.0_152-release-1136-b39 amd64
JVM: OpenJDK 64-Bit Server VM by JetBrains s.r.o
Windows 10 10.0

 

(no breakpoint is in debug settings list)

0
Comment actions Permalink

Stiv,

could you please specify which debug you're referring to? In case you mean Node.JS debug then it's better to submit a separate issue:

https://youtrack.jetbrains.com/issues/WEB

0

Please sign in to leave a comment.