Can not catch break point when remote debug python codes in Maya

I tried to follow steps introduced in http://tech-artists.org/forum/showthread.php?3153-Setting-up-PyCharm-for-use-with-Maya-2013 to remote debug python codes in Maya. I am using Windows 7 and both PyCharm and Maya are running in the same machine. Although I set breakpoints at the very beginning of the module, the breakpoint just cannot be triggered; the PyCharm keep "waiting for process connection".

The configuration of remote debugging is:

The simple test code is:


I have done all three steps in the configuration dialog box and I have checked the sys.path and the C:\Program Files (x86)\JetBrains\PyCharm 2016.1.2\helpers is in sys.path of both PyCharm and Maya. Also, the path to my test code is in both softwares. I ran the test code first in PyCharm by clicking the debug button with the "Maya 2016" configuration selected. But after I imported this python module in Maya and ran a function in it, the code just ran without being intercepted by PyCharm. Did I miss anything, or does that webpage miss anything? What aspect should I troubleshoot? Thank you for any help.

 

1 comment
Comment actions Permalink

It turns out that it is due to a bug of PyCharm that claims to be fixed but actually not: PY-4711 restarting remote debug issue

I've submitted a new issue ticket.

0

Please sign in to leave a comment.