$_POST not working on localhost

Hi Guys, 

 

i've noticed that $_POST is not working in the latest version of the IDE. 

 

I have a simple form:

<form class='form-horizontal' action='../admin-portal/test.php' method='post' role='form'>
<div class='form-group'>
<label for='username' class='col-sm-2 control-label'>Username</label>
<div class='col-sm-10'>
<input type='text' class='form-control' id='username' name='username' placeholder='Username' required>
</div>
</div>
<div class='form-group'>
<label for='password' class='col-sm-2 control-label'>Password</label>
<div class='col-sm-10'>
<input type='password' class='form-control' id='password' name='password' placeholder='Password'>
</div>
</div>
<div class='form-group'>
<div class='col-sm-offset-2 col-sm-10'>
<div class='checkbox'>
<label><input type='checkbox'> Remember me</label>
</div>
</div>
</div>
<div class='form-group'>
<div class='col-sm-offset-2 col-sm-10'>
<button type='submit' class='btn btn-primary' id='btn-login' name='btn-login'>Sign in</button>
</div>
</div>
</form>

that calls a basic php file to get the post values.


<?php
if(isset($_POST['username']))
{
echo "User name: ".$_POST['username'];
}
else
{
echo 'doom';
}
?>


This does not working in PHPStorm and is slowing me down dramatically.

I have testing this on my server and it works ... josephaspey.com/login.php


Can you guys look into this, or advise me how to install a previous persion e.g. 10.0.0 (I've read that this error
occurs since patch 10.0.1)
6 comments
Comment actions Permalink

The links on that thread are not useful. Can you advise how I set this to use my mamp sever?

0
Comment actions Permalink

Just create a deployment configuration ("Local or mounted folder") that will copy your project files into the webserver's root: https://confluence.jetbrains.com/display/PhpStorm/Deploying+PHP+applications+with+PhpStorm
Then, set up path mappings between the sources and the web root (so PhpStorm knows how files correspond to each other): Settings | Languages & Frameworks | PHP | Servers - add a new one, tick "Use path mappings".

0
Comment actions Permalink

Not working still in 2017... this should be CRITICAL

0
Comment actions Permalink

This bug wasted my 5 hours.This is really critical.

0

Please sign in to leave a comment.