How to avoid the autoscroll in project file window?

Hi guys,

I need a simple help for a stupid question:

The project file window focus the selection to the newest file and it autoscroll automatically. I have disabled the autoscroll as mentioned into the guide but the problem persists.

Any idea? thanks again for your effort!

Michelangelo

8 comments
Comment actions Permalink

Do I get you right, something creates files in your project dir (not PhpStorm), and then PhpStorm scrolls Project Tool Windows down to this file?
Could you please attach the IDE log?

0
Comment actions Permalink

Yes when I compile the source code within the project folder, new files are read and PHPStorm scrolls down.

https://dl.dropboxusercontent.com/u/18726427/idea.log

Regards

0
Comment actions Permalink

Could you please turn the Git Integration plugin off and check if it helps?

0
Comment actions Permalink

Same result ... no lucky

0
Comment actions Permalink

I'm having the same issue. Partly related: https://youtrack.jetbrains.com/issue/WI-32041

If newly created files are being opened in editor - please create another bug page with a detailed description at http://youtrack.jetbrains.com/issues/WI#newissue=yes

0
Comment actions Permalink

Could you please try the latest EAP and check if the issue reproduces there?

0
Comment actions Permalink

The problem are newest files created by the php compiler and stored in the same project folder. Is there a way to "disable" the update of a specific folder by the project view window?

thanks

0
Comment actions Permalink

You can mark this folder as excluded (via right click > Mark Directory As or via Settings\Preferences | Directories) so it would not be indexed or create a custom scope without this folder in Settings\Preferences | Appearance & Behavior | Scopes and then switch your Project tool window to this scope view as per <https://www.jetbrains.com/help/phpstorm/2016.1/project-tool-window.html>.

0

Please sign in to leave a comment.