Connection to <Database> failed

I'm trying to set up a connection to a postgres database over SSH with key. I think I have the settings right, but the connection is failing. It's entirely possible that one of the settings is wrong, but I'm not getting a useful error message that would help me figure out what's going on. When I press 'test connection', all I get is a dialog with:

title: "Connection Error"

body: "Connection to <database> failed\nThe connection attempt failed."

Is there a log file I can look at? A way to get more information?

10 comments
Comment actions Permalink

Hi Geoffrey,

Can you please attach screenshots of General and SSH/SSL tabs? You can find the log file in the log folder. Please also post it here after trying to connect if issue remains. 

Please see also SSH/SSL tab for reference.

0
Comment actions Permalink

I believe I ended up fixing it by changing the server to "localhost" to work with the SSH tunnel -- but neither the message I got in DataGrip nor the log file ended up being very helpful -- although I'm glad I know where to find the log file now.

Having said that, I'm not sure what else DataGrip could have done to diagnose the error. It can't know what should be in the server field. I can't think of anything to suggest to improve things. Anyway, it's sorted. Thanks.

 

2
Comment actions Permalink

I have the same problem. When connect to database via SSH I have error: 

MySQL - dev_pdainfo@localhost
Connection to MySQL - dev_pdainfo@localhost failed: SSH: Auth fail.
SSH: Auth fail

log file - https://drive.google.com/open?id=0B7DKBqWnp6FmMHRobDBpRnBfYzQ 

 

1
Comment actions Permalink

Hey,

since the update to 2017 it seems the password wallet has trouble to "remember" the passwords as it did before the update. Also i noticed then when connecting via SSH tunnel I can verify the connection works within the edit window of the connection. but as soon as i save the settings and try to actually use those connection settings it always gives: USERAUTH failed

I can easily connect via command line or with any other mysql client - like mysql workbench for example.

I have the feeling something is wrong with the password wallet. Intellij lost its memory about all previous entered/stored passwords.

I now have this issue with latest build:

 

 IntelliJ IDEA 2017.1.2
Build #IU-171.4249.39, built on April 25, 2017
Licensed to XXXXXXXXX
Subscription is active until March 18, 2018
JRE: 1.8.0_121-b13 amd64
JVM: Java HotSpot(TM) 64-Bit Server VM by Oracle Corporation
Linux 4.10.11-1-ARCH

0
Comment actions Permalink

The same problem, loosing the passworkds wallet.  Connects ok on the setting up of the connection but cant show after the db contents.

0
Comment actions Permalink

Sounds like this is worth filing as a separate issue?

0
Comment actions Permalink

Yes, also my problem was with a postgresql connection. isn't the drivers, y phpstorm passwords functionality.

If I uncheck the remember password, also doesn't work, never ask me the password on the connection process, just fails.

0
Comment actions Permalink

I have the same issue.

0
Comment actions Permalink

Changing the save passwords behavior to In KeePass instead of native keychain may help to fix this issue:

 

0

Please sign in to leave a comment.