Can I stop the in-IDE terminal from stealing focus of cmd-`, cmd-f and others?

Whenever I have a Terminal open and active in Rubymine, I can't use my favorite keyboard shortcuts for things like Find in files and switch windows.  Is there a way to customize what it steals and doesn't?  I understand there's a need to hang on to things like ctrl-c, but I keep ending up with a prompt like this: $ ```` 

 

:)

 

2 comments
Comment actions Permalink

You can disable 'Override IDE shortcuts' in Preferences | Tools | Terminal.

Related tickets: https://youtrack.jetbrains.com/issue/IDEA-133089, https://youtrack.jetbrains.com/issue/IDEA-123442

1
Comment actions Permalink

Thanks, disabling "Override IDE shortcuts" fixed the issue for me. This was driving me nuts. I don't understand why the terminal focus should disable shortcuts it doesn't even use itself (in my case Cmd+Shift+F for Find in Path).

0

Please sign in to leave a comment.