WebStorm works very slow

I have System requirements:

- Intel(R) Core(TM) i7-3770 CPU @ 3.40GHz

- 8 GB RAM

- x64-based Operating System Windows 10

But I works too slow. I have freezes on file scroll, slow file indexing after it's opened. I changed some parameters in webstorm.exe.vmoptions to improve perfromance:

-server
-Xms800m
-Xmx1050m
-XX:MaxPermSize=250m
-XX:ReservedCodeCacheSize=240m
-XX:+UseConcMarkSweepGC
-XX:SoftRefLRUPolicyMSPerMB=50
-ea
-Dsun.io.useCanonCaches=false
-Djava.net.preferIPv4Stack=true
-XX:+HeapDumpOnOutOfMemoryError
-XX:-OmitStackTraceInFastThrow

But it is still luggy. What can I do to fix it?

3 comments
Comment actions Permalink

I want to add one note. The average memory load is about 1400 MB. It's very bad...

1
Comment actions Permalink

Please try taking CPU snapshots when it runs slow. See https://intellij-support.jetbrains.com/hc/en-us/articles/207241235-Reporting-performance-problems for instructions.
Also, how big is your project? I'd suggest excluding all dynamically generated folders (if any) from your project (Mark directory as/Excluded). Other directories you don't need to get completion from (auxiliary node_modules, bower_components, etc.) can be excluded as well.
Please also read http://tomaszdziurko.pl/2015/11/1-and-the-only-one-to-customize-intellij-idea-memory-settings - you may find this article helpful.

0
Comment actions Permalink

Before update haven't had such issue. Last not slow working version was for me 2016.1.3. As of 2016.2 much slower without excluding.

2

Please sign in to leave a comment.