59 comments

Yes, Please. This is very annoying. Everytime Intellij tries to run indexing and freezes. There's no way to get out of here unless I kill it forcibly. I've to use git with Intellij so I am stuck. 

Please fix this. 

 

0

+1 on this, Downloaded Webstorm last week and I am trying to import a project that I've been working on. It simply does not work in Webstorm. I've exhausted all possible fixes at this stage!

0

Hi, same problem over here but I kinda understand what Elena is saying (moreover, debugging with our messages must be hard :) )

Nevertheless: would it be possible to at least add a window showing WHAT is beeing indexed? It would at least allow users to decide what to exclude (and not to do it random) + to understand the behavior and eventually report a bug more precisely, what do you think? I think it can be a hotfix that could be a first good step in the overall resolution of the disturbance in the user experience

 

Kid regards

2

That said, doing:

- File/Invalidate caches, Restart

- and marking my node_modules as Excluded

solved my problem.

 

But blindly excluding directories is from my point of view a workaround :)

1

I agree with Monika that having a list of which files are being (or were just) indexed would be extremely useful.  In my case with PyCharm, I know that the reindexing is triggered by local test runs, so it's probably caused by auto-generated assets which are being rewritten every time (even through the content almost never changes for any given file).  I'm about to start inspecting the filesystem to see which files in this (very large) project have changed in the past X minutes in order to mark them as excluded, but this would be much easier if PyCharm would just show me the exact directories and/or files that it had to reindex.

Also, given the amount of time spent reindexing even when virtually none of the file content changed, it seems that a reindex is triggered on every timestamp change.  Could it be optimized to cache a hash of each file's content so it would only reindex the file if the content hash has actually changed, instead of just blindly reindexing every time?

0

Excluding directories with generated stuff made a huge difference for me. For my javascript projects unit test coverage data and minified distribution copies are large. It would be very convenient to have a preferences item to automatically exclude from indexing any top-level directory named "coverage" or "dist", for example, instead of having to do it on every project.

Another thing that made a big difference for me was increasing the JVM heap parameters as discussed elsewhere on this site.

0

>It would be very convenient to have a preferences item to automatically exclude from indexing any top-level directory named "coverage" or "dist", for example, instead of having to do it on every project.

 

Please vote for https://youtrack.jetbrains.com/issue/IDEA-150784 and https://youtrack.jetbrains.com/issue/IDEA-127753.
Note also that you can use 'Ignore files and folders' option - see https://youtrack.jetbrains.com/issue/IDEA-127753#comment=27-868409

0

for me removing the config directory fixed it, lost all my configs but it doesnt indexing nemore maybe when the upgrade for 2016.3 came out the paths got messed up, i determined it was indexing the home folder by hovering over the indexing icon, occasionaly you will see files that are being indexed in a popup, it be nice to make the popup not disappear when every new indexing file but to leave the popup displayed when hovered and have a rolling log 

1

I concur. I annoys me that it _does_ report what it is indexing, but that it does that in a manner which is nearly completely useless, because it goes too quickly to actually see.

0

The time taken to index is the main problem for me.  I've given up using any unnecessary plugins because when they update it triggers an index, but this isn't really that much of a bother for me.  It's the startup that's the real killer, and here's my proposal: add the ability to use the existing index on startup, rather than re-indexing.  An option called "enable indexing dialogue" that turns on a startup-time popup saying "do you want to re-index your project?" would give me the ability to indicate whether any files have changed, and therefore whether the existing index is still valid.  Most of the times I start Intellij I'm actually restarting it, and therefore no change to the indexes are required.  If they could be serialised to disk and reloaded into memory in an efficient manner, I could skip the startup reindex.

1

I've been using WebStorm 2017 (early access https://confluence.jetbrains.com/display/WI/WebStorm+EAP)

for a couple of weeks now, and I don't have any issues with indexing anymore.

(copied over all 2016 settings to 2017 during installation)

When I open the same project in WS2016 the annoying indexing starts again. Back to 2017 and everything is good again.

WebStorm 2017.1 EAP
Build #WS-171.3224.7, built on February 14, 2017
WebStorm EAP User
Expiration date: March 16, 2017
JRE: 1.8.0_112-release-b702 x86_64
JVM: OpenJDK 64-Bit Server VM by JetBrains s.r.o
Mac OS X 10.11.6

0

Yah, this usually happens everytime I run `npm link` to link to another node package locally on my system. Seems to go crazy on the node_modules folder in the project that I've linked from.

1

I accidentally opened my personal folder, and Pycharm started indexing all my subfolders inside that. Would be great if we can stop indexing files if we make some mistake as this.

2

Keeps indexing about every 3-5 minutes even when actively editing and uses very large amount of memory. (Both WebStorm and PhpStorm)

Certainly a big problem while editing, please help to provide a solution for this. Thanks.

1

IntelliJ idea: What about start indexing after each run testng tests: only output report files are updating what is actually included in .gitignore file.


It looks like a solution:
Appearance & Behavior / System Settings -> Synchronization / Synchronize files on frame activation -> disable

From a post: https://intellij-support.jetbrains.com/hc/en-us/community/posts/206592105/comments/205980969

PS: Please, correct me if I am wrong and this feature is helpful in other cases

2

 Webstorm is indexing folders in node_modules even though it is ecluded.

This is the problem I am having.

When I look at the folders in node_modules in the Project window, although all sub-folders have a the lighter background color signifying they are excluded, the folder symbol for directories that are referenced in my package.json are grey in color (the others are brown).  These folders are being indexed on startup and it is completely consuming cpu resources so I can't do anything else.

When I right-click on these folders that are referenced in package.json, I get the option to "un-exclude" them, so they are excluded.

Elena, what can I do?  You recommend to exclude the folders I don't want to index and I have.  But the indexing is done anyway.

It seems like the option to suppress indexing is ignored if there are references into that folder in package.json

0

This problem has caused me to fail one of my classes. I was on an extremely tight deadline, and PyCharm crashed, when I went to load it back up, it took over 6 hours to reindex everything. I had to give a presentation of my project for my final and I couldn't do anything but talk about what my project would be like if it would load. Which was especially embarrassing because I had been trying to convince the teacher to switch over to Jetbrains products all semester. 6 hours to index? I wonder how that works with a 8 hour workday?

2

I'm also suffering from indexing locking the entire app - all with local files on a Mac.

I'm amazed that this is STILL a bug after a year, and the suggestion that we mail support with some logs every time this happens is quite frankly laughable. If there's an underlying problem like permissions or something, then say so. That a lock-up is possible with local files seems odd.

Strikes me that JetBrains has become a bloated company selling bloated and buggy software, and I yearn for version 6 and the like where there were fewer bells and whistles, but it just worked.

0

I'm using PhpStorm 2017.1.3 (Win10) and I have had the same problem. Even mouse pointer became sluggish before. I hadn't excluded anything from indexing, but noticed that you can make PhpStorm more usable by setting priority "Below normal" (Task Manager > Details-tab > (right click PhpStorm executable) > Set priority > Below normal). Now, even though it's indexing, editor is usable.

 

0

Actually my problem is slightly different in that the twirler stops twirling and whole IDE locks up. The solution for me was to roll back to version 6 of PHPStorm!

0

Indexing might be a feature, but it really got in the way. 

It would be much better if you could run that task in a low priority thread. When phpStorm start to indexing, my machine almost get unusable. If that task would only take a small portion of the processing power available you would have far less complain. I really don't get why after all that time you didn't fix it.

If indexing is so important, at least make it so it doesn't get in the way and stale our machines.

my 2C.

0

I was having this issue too, with all (or many) of the symptoms described by the folks above: very slow indexing, random reindexing out of nowhere, etc. I think I found how to fix it (at least, in our case)

We've got a big project with thousands of source files in different languages: Java, JavaScript, TypeScript, Angular 1/2/4, GO, HTML for a start. As I found, it was not a problem. The problem was that there was a non-excluded folder buried deep inside the source tree where our system dumped too many log files, like hundreds of them during a single debug session. When I found it, it contained over 600'000 small useless files. After I deleted it and ensured new files are not dumped there, everything started to work much better.

So two things:

1. Recommendation to users: try to find out what's causing reindexing. On Windows, there is a number of tools that can watch changes in a folder and its subfolders. Find a tool (or write your own like I did, it's easy - look up FileSystemWatcher). Run this tool pointed to your source folder root while running IntelliJ/WebStorm/PhpStorm and find out what files are changing, then figure out why.

2. Recommendation to the IntelliJ team: add a warning to the IDE that there is a indexable folder that contain too many files. 

1

Guys, please add a functionality to disable indexing, please, please do.

0

try the option invalidate cache and restart, that worked for me in rubymine

0

For me the same problem is happening. I've tried to invalidate caches, and the reindex is running for at least half an hour. My workstation also is an i7 with 8G RAM. I think an option to solve this problem is to reindex just the changes in the files, not everything. I think it is unreasonable to reindex every time PhpStorm starts, even if I did not change any file since I closed the editor in the day before.

Correction: The project files were on network mount. I've reopened the project in PhpStorm as an external mount, the PhpStorm made a mirror in a different, local directory. Now the Indexing seems to be faster..

0

I just updated a plugin (AceJump, which I love) and it started reindexing on startup.  No new .java changes, only a few html/js changes...ugh!   This will be a 10min operation during which the IDE is unusable.

0

Vinicius C. Brand 8GB ram?!  You need to upgrade.  16 is min, and 32 is comfortable.

-2

Hi, I'm using it on a Mac and have latest version. Now I'm trying to create new project 'Using existing files on remote via SFTP'. Got stuck in phase Create New Project: Choose Remote Path. All options are grayed out an I cannot even set Project Root because '... PHPStorm is updating indices'. Project is huge but line is fast enough ... Now waiting for about 15 minutes.

It is not normal.

M.

0

Miroslav Novak - maybe you have the same issue I do (although my project is small and local). I presume yours has locked up. I fixed it by reverting to version 6.0.2!

I might have a play with 2017.03 and then submit the error log or whatever it is into the issue tracking system.

0

Post is closed for comments.