Mac OS X comment block - command + slash

Answered

Hi,

I'm new using Rubymine. I want to know how to comment blocks of code but when I use the shortcut (command+slash) help menu is showed.

How can I comment blocks of code in Mac OS X?

 

Best regards.

12 comments
Comment actions Permalink

What is your system keyboard layout? What shortcuts are assigned to 'Comment with Block Comment' and 'Help' actions in Preferences | Keymap?

-1
Comment actions Permalink

I have this problem, too, Italian layout.

1
Comment actions Permalink

Same problem, but in Intellij. Comment block CMD + SHIFT + FORWARD SLASH (or Question mark) clashes with OSX key-mapping. Take a look at https://support.apple.com/en-gb/HT201236 

You can see:

Shift–Command–
Question mark (?)
Open the Help menu.

I'd gladly disable OSX help keymap as I don't care for that, if I knew how... 

0
Comment actions Permalink

To diable OSX key mapping just follow below steps:

Click on Apple icon => System Preference => keyboard => shortcuts => App shortcuts=> uncheck show help menu

10
Comment actions Permalink

Apart from "show help menu", CMD-/ is also clashing with "hide or show the status bar in Finder" :/

1
Comment actions Permalink

I've the same problem, if it matters work fine with mac keyboard with numeric pad but not with the wireless compact one, and i have already disabled the app shortcuts.

Another thing if i press CMD + ( SHIFT + 7 = / ) with opened code menu the shortcut works, but if is close i see che code menu highlighted

0
Comment actions Permalink

I have the same problem as Raffaele Decarli. Only this is for my built in Macbook Pro keyboard with Touch bar. 

2
Comment actions Permalink

Same problem. Surprised this is still alive.

2
Comment actions Permalink

same problem. any solutions yet?

 

 

0
Comment actions Permalink

Hello,

there's a corresponding request on our tracker, please check the proposed workaround:

https://youtrack.jetbrains.com/issue/IDEA-212375#focus=streamItem-27-3481946.0-0

0
Comment actions Permalink

i solve this problem this way.

firstly you have to go pycharm>preferences menu. you will see keymap sub menu left side on windows then click here.

then you will see main menu right side open this menu's sub menu, you will see code sub menu.

comment shortcut is here(this area name is -comment with line comment-) . you need clear others shortcut and add new shortcut here.

 

0
Comment actions Permalink

This information is really very useful for all Mac users. I was facing iTunes verification error. I have verified this properly but again it is showing iTunes verification failed. I am looking for the proper solution.

0

Please sign in to leave a comment.