WebStorm is blocking JavaScript components?

I am using the MaterializeCSS framework which has JavaScript components such as modals, dropdowns, etc. Also AngularJS, where I am loading partial views using templates.

None of the JavaScript components are working if they're included inside one of the templates. They only work in the index.html file. The thing is that this only happens in my machine, because if I try the generated HTML in a codepen.io or similar sites everything goes perfectly. So there mustn't be any issue about the DOM or the styles. It must be the IDE that's blocking something.

5 comments
Comment actions Permalink

Not sure what you mean by 'blocking'. WebStorm itself doesn't run your application, it just starts the browser passing the specified URL to it. Looks like you didn't set everything up properly

0
Comment actions Permalink

I have been trying more tests, and I found out absolutely no JavaScript is being executed in the partials. For example, if I add the following:

<script>alert('test')</script>

nothing happens. It only works in the index.html file.

What could it be?

0
Comment actions Permalink

No idea. Sample project would be helpful. BTW, do you see any errors in debugger console when debugging your application?

0
Comment actions Permalink

No. No errors. The JavaScript is simply not being executed.

0
Comment actions Permalink

may be, partials are not loaded or rendered? Once more: no information to figure out the problem, project is needed

0

Please sign in to leave a comment.