2016.2 very slow

Hi,

I've upgraded to 2016.2 today (Build #PS-162.1121.38, built on July 12, 2016) and immediately noticed considerable slow down when doing anything in the IDE (editing any file, running any Grunt/Gulp jobs, etc.). Basically, the same thing described here https://youtrack.jetbrains.com/issue/IDEA-157837. Actually, IDE just stopped responding after running one of the Grunt jobs now (which I'm running every day multiple times and never had issue up til now).

Unlike that ticket mentioned above, I'm on Ubuntu (16.04) and have a decent workstation laptop (quad core i7, 16GB RAM, SSD). I'm interested if anyone else is experiencing the same issue?

Thanks.

39 comments
Comment actions Permalink

I experienced the same problem with 2016.2: completely unusable!
I am back on 2016.1

My System:
i7 3.33 GHz, 24GB Ram, 1TB SSd, Windows10 64Bit

Actually working on an AS3/Flex program.
After a debug session it is impossible making edits. Even adding a line of comment (!) takes half a minute before the IDE comes back.

After "Invalidate Cache / Restart", it's working almost normally for a very short while. But lastest after the next run you had to clear cache again. Unacceptable!

6
Comment actions Permalink

For anyone who happens along... apparently it can creep up on you.  I'd been running 2016.2 fine for almost 2 months... and then it happened.  No matter what I disabled; no improvement. No clue what changed from one day to the next; same projects, no other issues.

I7, SSD, 16G, Ubuntu 16.04

Back to 2016.1 as well.

 

2
Comment actions Permalink

I have the same issue described above by many.

Idea (2016.2.5) is very slow, sometimes it takes a few seconds to react on typing the code. The scrolling of the code window is not fluent any more (jumpy, sometimes it does not move again for a few seconds).

According to the Activity Monitor (yes, I am on the most powerfull MaxBook Pro 15/2015), Idea eats over 300% os CPU (3 cores). The coolers never stop when I start working with Idea.

It actually drives me mad as I love Idea features but this can easily make it a no go as it significantly decreases my productivity (but where is any replacement, Eclipse, Netbeans, ???)...

BTW: I am not using PHP Storm, it is just Utlimate with Python pugin and web development enabled (I was just googling before filling my own ticket). I am editing the Python (a lot), JavaScript (a lot), HTML (rarely), CSS (rarely). I am also using the JavaScript/Chrome debugger...

2
Comment actions Permalink

Hello,

Did you exclude the folders where Grunt/Gulp place generated files from the indexing (mark as Excluded in Settings\Preferences | Directories or via right click)?

1
Comment actions Permalink

Person in the neighbouring thread had somehow similar issue (delays after typing).

After providing performance info .. it appears to be caused by bookmarks. So .. try removing bookmarks -- any difference?

https://youtrack.jetbrains.com/issue/IDEA-156735

Otherwise please provide performance info: https://youtrack.jetbrains.com/issue/WI-32548#comment=27-1525323

1
Comment actions Permalink

Excluding as many folders as possible worked for me. Indexing large files created by Grunt/Gulp every time after a build was probably the cause of this problem but I excluded other folders too.

1
Comment actions Permalink

Hi,

Well, what folders are those? I have excluded folders like bower_components and node_modules from indexing. As for hidden folders (starting with dot) - I think they are not included in indexing by default.
I'll just repeat that I'm experiencing "slowness" while editing any file (PHP, Javascript, HTML, CSS...) - it's like the background parser (syntax checker, all the other inspections) has just slowed down for some reason.

Anyway, I reverted back to 2016.1 (Build #PS-145.1616, built on May 24, 2016) and that version works ok (everything is fast, Grunt job that halted in 2016.2 is working perfectly ok here...).

0
Comment actions Permalink

That's strange.

It would be great if you could provide CPU snapshot taken when the performance issue is present in 2016.2. Instructions for taking the snapshot are available here: <https://intellij-support.jetbrains.com/hc/en-us/articles/207241235>.

Feel free to submit a support issue via Help > New Support Request.

0
Comment actions Permalink

> I experienced the same problem with 2016.2: completely unusable!
> I am back on 2016.1

the same

 

0
Comment actions Permalink

Same here. 2016.2.3. Indexing node_modules is horrible slow and basically makes the whole suite unusable.

 

0
Comment actions Permalink

It's recommended to mark `node_modules` as excluded and add it to Include Paths instead.

0
Comment actions Permalink

I have the same issue. It just gets slower over time. After restart we have 10min of "normal" work and after that the IDE becomes almost unusable. It is unacceptable for paid product !

0
Comment actions Permalink

Hi,

I use
Since yesterday I have the same issue as described above: typed letter take several seconds to appear on screen.

I tried to change the memory settings but it says it cannot be changed because I am in 32 bits.

the fact is I'm in 64 bits !... ???

I read in some other thread the cause could be bookmarks. i 'm not aware of using them unless I have added some by unwillingly typing some shortcuts. How can I check if I have some and remove them ?

when I tried enabling CPU profiler, phpstorm crashed ...

I did have 8 or 9 php storm project open when the problem occured, but it use to work fine and I do not think those projects are very big

Any input on this very anoing issue is very welcome

 

0
Comment actions Permalink

@V2belleville

>I tried to change the memory settings but it says it cannot be changed because I am in 32 bits.

>the fact is I'm in 64 bits !... ???

Nope -- you are using 32-bit Java. 64-bit here means Java's JRE that is used to run the IDE (you can see that info in About screen -- your screenshot tells just that).

You need to install 64-bit JDK and use 64-bit launcher instead of usual 32-bit (check this thread for some more info)

0
Comment actions Permalink

@V2belleville To run the IDE in 64-bit mode you will need to download and install 64-bit JDK (not JRE) distribution and install it yourself. 

Please see https://intellij-support.jetbrains.com/hc/en-us/articles/206544879-Selecting-the-JDK-version-the-IDE-will-run-under for details.

You would need to start PhpStorm with 64bit executable, i.e. C:\Program Files (x86)\JetBrains\PhpStorm 2016.1\bin\PhpStorm64.exe

0
Comment actions Permalink

thanks Andriy and Dmitry

I would recomend JB guys to change the message from "the value should be less than 800 for 32 bits systems" to "32 bits java and 32 bits PhpStorm executable". would be less confusing for nerds in configuration issues like me ...

In the thread quoted by Dmitry I read

> 32-bit java runs faster and consumes less memory

Are you guys confident that using 64 bit java will solve my phpstorm problem and not create memory issues to my whole system ?

 

0
Comment actions Permalink

> Are you guys confident that using 64 bit java will solve my phpstorm problem and not create memory issues to my whole system ?

Not really since it's often depend on a project. 

Initially I can see you're running PhpStorm using Oracle JDK - this might be a reason for lags. 

I would suggest to download & install EAP build and check how it would work for you.

0
Comment actions Permalink

As for 

> I would recomend JB guys to change the message

 

 - please submit this as a feature request to our tracker at http://youtrack.jetbrains.com/issues/WI#newissue=yes

0
Comment actions Permalink

hi Dmitry,

what does EAP build change ?

I find it very odd that I should install something more since phpStorm worked fine for me for more than a year. I remember now that it started bugging after i saw a message about indexing, it stayed for quite a time, did not really payed attention at the time.

What does phpstorm index ? what is it used for ? Is there a chance that this is the cause of my problem ? Can I desable indexing ?

0
Comment actions Permalink

@ V2belleville

> What does phpstorm index ? what is it used for ? Is there a chance that this is the cause of my problem ? Can I desable indexing ?

Files in a project. Indexes used for code completion & navigation. Can't say for sure if indexes are the issue you can run File > Invalidate Caches/Restart > Invalidate and Restart to check. Indexing can't be fully disabled. You can mark all the folders as excluded but that would turn IDE into a simple text editor.

@ Jiří Křivánek

Please restart IDE and attach/upload anywhere your log folder archived Help > Show log in Finder).

0
Comment actions Permalink

Please download the requested log from here:

https://www.dropbox.com/s/8ea9cfjq47gfmrz/idea.log?dl=0

I tried to observe the behavior, just putting the activity monitor along with the IDEA:

  • Whenever I type something more complex than just a white char (like space) - e.g. the text "var myVar = 10;", the CPU of IDEA immediately rises to over 300%
  • If I do only this and wait a moment, within a few seconds, the CPU usage gets back to normal (around 1%)
  • But if I continue editing my source code, the CPU remains over 300% all the time, soon resulting in coolers rorating full thortle and the MacBook looks like preparing to take off :)

BTW: I looked into the log you pointed me to and spotted that there are enormous amount of low memory problems:

  • So I edited the Custom VM options to look like this (so that there should be plenty of RAM available now - my MacBook has 16GB):
-Xms1024m
-Xmx5000m
-XX:MaxPermSize=350m
-XX:ReservedCodeCacheSize=96m
-XX:+UseCompressedOops
0
Comment actions Permalink

Jiri, you're running on Oracle JDK, that's what most probably is causing the issue.
Please try re-downloading the package and install IDEA again from there, it should bring the built-in JDK back.
If it doesn't help, please also try to run for a while with all custom plugins disabled (Settings | Plugins | Show: Custom)

0
Comment actions Permalink
  1. I am sure I did not change anything to move IDEA under Oracle Java.
  2. I tried what you adviced (actually, there seems to be new version so I did two in one)
  3. It installed over 1GB
  4. But when I open about, I can see I am still under Oracle Java
  5. What can I do to move the the built in one (I will also try to Google this)?
  6. I disabled all custom plugins (except of the Python one which is anyways JetBrains) and will give it a try tonight and will report back

0
Comment actions Permalink

So I managed to switch to JetBrains Java according to this post:

https://intellij-support.jetbrains.com/hc/en-us/articles/206544879-Selecting-the-JDK-version-the-IDE-will-run-under

Now I am starting to work on it (two changes doen in parallel so if it is solved I do not know which helped me out :) )

0
Comment actions Permalink

Thanks, please let us know how it goes

0
Comment actions Permalink

So I gave it a few days for testing with these observations:

  • Switching to built in Java improved things a lot
  • IDEA is still consuming a lot of CPU (my MacBook Pro fans are still running but not full throtle)
  • IDEA is not freezing/lagging any more
  • IDEA can be normaly used for my work again

Thank you for your support!

0
Comment actions Permalink

Thanks for the update. In case you want to check the issue with CPU - you can capture a CPU snapshot during the time when CPU is overused with help of this article: https://intellij-support.jetbrains.com/hc/en-us/articles/207241235-Reporting-performance-problems

Then you can upload the snapshot to our FTP and notify us about it.

0
Comment actions Permalink

Hey there guys - I have just updated to 2016.3: It is pretty impressive: The MacBook coolers are now shut off, idea keeps under 80% of CPU (while before this update it used to be over 350%)!!!

Thank you for doing this for us and please keep improving it this way...

0
Comment actions Permalink

I'm on 2016.3 on mac and it tends to get very sluggish after a few days of debugging and open/closing lid of laptop over several days.  Typically need to restart pycharm to fix.

0
Comment actions Permalink

Hey, i've been having the same or similar issues as descibed above. I'm on Ubuntu 14.04 LTS 64-bit Dell laptop with i7 16 GB Ram 256 SSD, should be resonably quick, but no ...

 

However, i found a post on Ask Ubuntu (SO-based), suggesting an install of xubuntu, "sudo apt-get install xubuntu", whereafter i restarted my laptop, logged onto xubuntu desktop.

 

And now everthing is bright and shiny, opening up IntelliJ in the latest version (2016.3.2) was all of a sudden a breeze, no long indexing, or mysterious timeouts, everthing just flows.

 

In the post on Ask Ubuntu, a possible reason for Ubuntu being so sluggish, could be caused by Unity being resource-consuming.

 

Would recommmend looking into installing xubuntu

 

Cheers Kalle

0

Please sign in to leave a comment.