Docker integration: launch using 'nvidia-docker' and install cython speedups

Hi,

Trying to use docker with PyCharm.  Mostly works, but have two questions:

  1. Is there a way to install the cython debugger speedups standalone in the docker container?  That is, without a full installation of PyCharm itself.

  2. Instead of running the container using the 'docker' executable, I'd like PyCharm to use 'nvidia-docker' (for GPU access).  Is there a way to change this somewhere?

Thanks!

5 comments
Comment actions Permalink

Hello,

  1. I've created the issue https://youtrack.jetbrains.com/issue/PY-20269. Please see the workaround in the comment below this issue for installing cython speedups.
  2. Actually docker client executables are not used in PyCharm and IDEA Docker integration. To use nvidia-docker you should specify its API URL and Certificates folder (if necessary) in Settings dialog in Build, Execution, Deployment > Docker menu.

 

0
Comment actions Permalink

2. I've tried to get PyCharm to connect to the nvidia-docker-plugin but I'm pretty sure you are supposed to just give the correct flags when running docker by asking the plugin via something like curl for the devices and such. However PyCharm doesn't allow for adding these flags like they allow for adding the API URL. Is there some way I can add my own flags to the docker command that ends up being called so I can pass the GPU to the docker container?

0
Comment actions Permalink

nvidia-docker support in pycharm would be nice...

0
Comment actions Permalink

Someone found a solution for 'nvidia-docker' integration with PyCharm ?

An alternative way is to use SSH connexion ... but it requires to installl/add packages in images to allow SHH connexion.
And path-planning for sources is not easy to setup.

I'm always looking for a solution that uses Docker integration tools from PyCharm !

0
Comment actions Permalink

Hi,

possible answer/workaround for question no. 2:

https://github.com/NVIDIA/nvidia-docker/issues/303#issuecomment-415668695 

simply change docker "default-runtime" to "nvidia" by adding line

"default-runtime": "nvidia"

to your "etc/docker/daemon.json" file

0

Please sign in to leave a comment.