PhpStorm slow / delay on pressing keys

Hello

 

I use 2016.2 PHPStorm

 

It's very slow when pressing keys

 

demo here - https://www.youtube.com/watch?v=5IQmEkrEpkk

 

when pressing multiple keys the delay is even longer!

 

I have a rMBR 2014 2.3 Ghz Quad core and this is becoming ridiculous 

 

can we disable features that cause this  ? 

 

I have tried file > Invalidate caches but does not do much

 

Thanks!

6 comments

even going into power saver mode does not make the delay go away

0

Guys this is ridiculous

Even turning on POWER SAVER MODE does not solve anything

This IDE is getting worse by each update

https://www.youtube.com/watch?v=dtEM0PTQyio

 

 

0

Hello,

Looks like you have a huge project there.

Please go to Help > Diagnostic > Change memory settings and set Xmx value to 1536 or 2048 (depends on the amount of RAM you have) and press "Save and Restart".

0

Yes, all of my projects are kind of big.

 

I cannot find Help > Diagnostic ( Mac ) 

 

I can find Help > Edit Custom VM Options 

 

I doubled all the values there

 

is that ok ? 

0

DOES NOT WORK

 

I increased HEAP SIZE

 

disabled ALL inspections

 

Waste of money this IDE really.. if you don't fix this

 

Can I send you debug log or something ?

 

I'll have to use netbenas for now

 

 

0

Hello,

Let's move to https://youtrack.jetbrains.com/issue/WI-32548 - our team already asked for some additional data there.

0

Please sign in to leave a comment.